Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Определить значение переменной Z, которое будет получено в результате выполнения фрагментами программы, написанной на языке Поскаля:

5-9 класс

x:=3,y:=2,x:=y,z:=2 if x больше y then Z:=y-1; else Z:=x+1

мария2001541307 01 нояб. 2013 г., 2:47:47 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Oli4ik33
01 нояб. 2013 г., 5:24:40 (10 лет назад)

x = 2 будет, т.к. y=2, 

затем if(x>y)

условие ложно (x и y оба равны 2 и x не больше чем y), поэтому выполнится блок else z:=x+1,

 

то есть z = 3;

Ответить

Другие вопросы из категории

Помогите сделать 2 задания , пожалуйста
перевести числа

1010101-2 ичная система + перевести в 10-ую
172 в восьмиричной перевести в десятичную
2EA шестнадцатиричная перевести в десятичную
243 шестеричная перевести в 10
513 в десятичной перевести в 8 - 16 ричную
600 в десятичной перевести в 8 - 16 ричную ситему

Задача «Вирусы»

Для моделирования различных объектов часто применяются так называемые клеточные поля. В простейшем случае – это прямоугольные таблицы, характеризующие некоторую область, а в каждой ячейке таблицы записывается какая-либо информация об исследуемом объекте. В биологии для моделирования распространения вирусов на плоской области в каждой ячейке помечается наличие вируса, а его распространение осуществляется в соседние ячейки по вертикали и горизонтали за одну единицу времени. Некоторые клетки обладают иммунитетом, заразить их невозможно и через них не распространяются вирусы. Требуется написать программу, которая определяет минимально возможное число вирусов, с помощью которых можно заразить всю исследуемую прямоугольную область (за исключением защищённых клеток).
Описание входных данныхВ первой строке входного файла input.txt записаны два натуральных числа n и m -размеры таблицы (количество строк и столбцов соответственно). Известно, что 1 n, m 100. Во второй строке вначале записано одно число k – количество защищённых клеток, а далее записаны 2k чисел – координаты этих клеток xi, yi (0 k n m, 1 xi n, 1 yi m).
Описание выходных данных
В единственную строку выходного файла output.txt нужно вывести одно число –минимально возможное число вирусов.
Примеры входных и выходных данных
input.txt
4 5 3 1 3 2 1 2 2
output.txt 2

Установить соответствие: Информационный процесс:

1.Хранение
2.Обработка
3.Передача
Примеры ,а).разговор 2 х друзей
б)песня по радио
в)перевод с английского на русский
г)фотографирование
д)
е)


Д) и е) свои примеры

Читайте также

1.Какое значение переменной S будет напечатано после выполнения фрагмента программы,записанной на языке программирования TURBO PASCAL:A:=2В: = 3;

if A>B then S: = A+B;
writeln (S);
Варианты ответов:1)5 ;2)6; 3)7; 4)8

2. Какое значение переменной S будет напечатано после выполнения фрагмента программы, записанной на языке программирования PASCAL:
S: =1;
N: =1;
while N<=3 do
begin
S: = S*N;
N: = N+1;
end;
writeln(S);
Варианты ответов: 1)2 ; 2)1; 3)0; 4)4

Подробности от учителя:1.Определить значение переменной у после выполнения следующего фрагмента программы:

y:=1;
For i:=2 to 4 do y:=y+i;

2.Определить значение переменной у после выполнения следующего фрагмента программы:
y:=0;
For i:=-100 to 100 do
If i mod 10 =5 then y:=y+i;

3. На промежутке [a;b] (a,b -целые числа, которые вводятся с клавиатуры) определить среднее арифметическое чисел кратных 7

Рассмотрите запись алгоритма на знакомом в большей степени вам языке. Обратите внимание, что расшифровать надо значение переменных и определить, что

будет выведено на экран в результате выполнения алгоритма. Необходимо учитывать начальное и конечное значение параметра цикла, начальное значение переменной S.

Определите, что будет напечатано в результате выполнения следуюшего алгоритма, записанного на трёх алгоритмических языках.

1) Определите значение целочисленных переменных a и b после выполнения фрагмента программы: a := 3 + 8*4; b :=

(a div 10) + 14;

a := (b mod 10) + 2;

2) Определите значение целочисленных переменных a и b после выполнения фрагмента программы:

a := 1819;

b := (a div 100)*10+9;

a := (10*b–a) mod 100;

3) Определите значение целочисленных переменных a и b после выполнения фрагмента программы:

a := 42;

b := 14;

a := a div b;

b := a*b;

a := b div a;

4) Определите значение целочисленных переменных x, y и t после выполнения фрагмента программы:

x := 5;

y := 7;

t := x;

x := y mod x;

y := t;

5) Определите значение целочисленных переменных a и b после выполнения фрагмента программы:

а :=6*12 + 3;

b :=(a div 10)+ 5;

a :=(b mod 10)+ 1;



Вы находитесь на странице вопроса "Определить значение переменной Z, которое будет получено в результате выполнения фрагментами программы, написанной на языке Поскаля:", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.