Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Задать случайный массив на интервале [-2;8].Найти количество положительных чисел .Нужна программа на PascalABC

5-9 класс

456123д 04 авг. 2014 г., 17:55:01 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dasha302000
04 авг. 2014 г., 19:57:26 (9 лет назад)

const nn=10;
var
A: array [1..nn] of integer;
i,k:integer;
begin
  Randomize;
  k:=0;
  for i:= 1 to nn do
  begin
    A[i]:=random(10)-2;
    write (A[i],' ');
  end;
  for i:= 1 to nn do if (A[i]>0) then k:=k+1;
  writeln;
  writeln(k);
end.

Ответить

Другие вопросы из категории

составте программу которая находит

произведение всех натуральных чисел от 1 до 20

Помогите пожалуйста, совсем не понимаю( Сами задачи по комбинаторике 6 класса.

1 задача: На предприятии работают 600 человек. Приход на работу фиксируется автоматом, записывающим номер пришедшего. Найти размер записи утром, если известно, что в этот день 100 человек по разным причинам не пришло.
2 задача: Задумано двухзначное число. Число считается удачным, если оно делится на 5 или содержит цифру 6. Сколько существует удачных чисел?
Заранее спасибо!

Читайте также

1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива.

2. Создать массив A из 10 элементов, заполненный случайным образом числами принадлежащих промежутку (0;20). Вывести полученный массив на экран. Вычислить количество элементов массива, значения которых не превышают среднее арифметическое значений его элементов.

1)дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов

2)Дан массив целых чисел.Найти сумму четных положительных чисел, стоящих на нечетных местах и количество отрицательных элементов, стоящих на четных местах.
3)дан массив целых чисел.найти сумму четных и положительных элементов, расположенных до первого отрицательного элемента.Примечание:при вводе необходимо учесть, что первый элемент не может быть отрицательным.

НА QBASIC!!!!!!!!!! 1)Для массива А. Найти количество положительных, сумму нечетных и произведение чисел, кратных В. Результаты расчетаа и

массив вывести на экран.

2)Для массива А опредилить сумму квадратов отрицательных элементов, произведение положительных элементов, нулевые-заменить числом 12. Результаты расчета и массив вывести на экран.

3)Известны данные о количестве осадков, выпавших за каждый день января. Найти общее число осадков, выпавших по нечетным числам месяца.

4)Известна стоимость каждого из 15 видов товаров. Напечатать номера тех видов товаров, которые имеют стоимость всех видов товаров.

5)Дан массив А, отсортировать его по возрастанию. Отсортированный массив вывести на экран.

6)Дан массив А, Отсортировать его по убыванию. Отсортированный массив вывести на экран.



Вы находитесь на странице вопроса "Задать случайный массив на интервале [-2;8].Найти количество положительных чисел .Нужна программа на PascalABC", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.