Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Паскаль, 10 класс. Прошу срочно помочь. Заранее спасибо!

10-11 класс

Задача №1:
Используя операторы цикла, рассчитать сумму ряда для значений x=0.5; 0.55; 0.6; 0.65; 0.7; 0.75. Включать в сумму члены ряда, большие или равные значению eps=0.00001. Проверить правильность вычислений для контрольной точки x=0.5. Сравнить полученные значения со значениями, рассчитанными по точному аналитическому выражению.
2x3(куб)/3-2x5/15+2x7/35-...+(-1)k+1*2x(2k+1)/4k2-1+..., f(x)=(1+x2)arctgx-x, f(0.5)=0.07955.

Задача №2:
Вводится последовательность целых чисел, по абсолютной величине меньших или равных 100. Найти и вывести на печать количество отрицательных чисел и среднее арифметическое значение всех чисел, расположенных после первого нулевого элемента.

Zodiakzm100 03 авг. 2014 г., 7:26:34 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Влада20031
03 авг. 2014 г., 8:13:57 (9 лет назад)

program project1;
uses
crt,math;
constn=10;
var  
s:real; 
 i,f,m:byte;  
a:array [1..10] of real;
begin  
m:=0;  
for i:=1 to n do 
 begin  
writeln('vvedite ',i,' cifru');readln(a[i]);
  end;
  for i:=1 to n do 
 begin
  if a[i]<0 then 
 inc(f);  
end;  
for i:=1 to n do 
 begin 
 if a[i]=0 then 
 inc(m); 
 if m<>0 then 
 s:=s+a[i];  
end;
 writeln('kolichestvo otricatelnih: ',f:2);
 writeln('summa vseh posle 0: ',s:2:2); 
readln;
end.

Ответить

Читайте также

Вычислите среднее арифметическое число положительных элементов массива A(N1), B(N2), C(N3)

Помогите пожалуйста очень срочно надо))), заранее спасибо)))

Помогите срочно нужно написать программу в Паскале по ветвлениям)

Ввести последовательно возраст Антона,Бориса и Виктора. Определить,кто из них старше. Пример:
Возраст Антона: 15
Возраст Бориса: 17
Возраст Виктора: 16
Ответ: Борис старше всех.

Пример:
Возраст Антона: 17
Возраст Бориса: 17
Возраст Виктора: 16
Ответ: Антон и Борис старше Виктора.

Заранее спасибо большое)



Вы находитесь на странице вопроса "Паскаль, 10 класс. Прошу срочно помочь. Заранее спасибо!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.