Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Переписать,

10-11 класс

исправив ошибки в программе:


Program
A;

Kissyla 19 сент. 2013 г., 14:54:02 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Motuz1
19 сент. 2013 г., 17:27:18 (10 лет назад)

ProgramA;

Var  b, a1: real;

begin
read(a1)  ;
b := a1 + 5;

a1 := b /2;

write (b, a1);

end.

+ 0 -
Diana132
19 сент. 2013 г., 18:33:52 (10 лет назад)

Комментарий удален

+ 0 -
Трикошки
19 сент. 2013 г., 20:19:10 (10 лет назад)

program A;
var 2b,a1: integer;
begin
read (a1);
for 2b:=a1 + 5;
for a1:=2b : 2;
write(2b, a1);
end;

+ 0 -
Lovely01
19 сент. 2013 г., 22:13:18 (10 лет назад)

После end - точка.

Ответить

Другие вопросы из категории

Пожалуйста помогите, заранее спасибо:)

Текст содержит 3 стр. по 50 строк, по 20 символов. Алфавит= 128 символам. Найти объем сообщение?

Некоторое десятичное число X перевели в системы счисления с основаниями 16, 8, 4, 2. Часть символов при записи была утеряна. Позиции утерянных символов

обозначены символом “*”: X= E*16= *5*8 = ***14 = *****1**2. Восстановите все числа и определите число X.

Читайте также

Создать на Паскале форму.

1. Население некоторой страны в 1904 году составляло а человек. По переписи населения, проведенной в прошлом году, зарегистрировано b человек. Составить программу вычисления среднегодового прироста населения за этот период.
2. Составить программу определения, является ли введенный год високосным?
3. Составить программу определения размера денежного вклада через t лет после его внесения, если заданы размер начального взноса n и банковский процент b.
4. Для условий из предыдущей задачи определить, через сколько лет размер вклада превысит вдвое первоначальный взнос.

Почему на этапе ввода последней ступени (т.е. задали х=5 и вводим 5 ступень) паскаль выкидывает ошибку: "Индекс находился вне границ массива", ведь al[x]

это его последний элемент, разве нет?
Код:

program s1;
var x, i:integer;
al, tl: array of real;
begin
writeln ('Введите количество ступеней ракеты'); read (x);
setlength (al, x);
setlength (tl, x);
for i:=1 to x do begin
writeln ('Введите ускорение ', i, ' ступени'); read (al[i]);
writeln ('Введите время работы ', i, ' ступени'); read (tl[i]);
end;
end.
P.S.: Переписать массив в статический не предлагать, нужен именно переменной длины. Заранее спасибо.

Дан файл f, компоненты которого являются целыми числами.

Найти количество квадратов нечетных чисел среди компонент файла. Записать это значение в начало нового файла g. Остальные значения переписать из исходного файла f.

ПОМОГИТЕ ПОЖАЛУЙСТА

результаты переписи населения хранятся в памяти ЭВМ. Элемент массива - год рождения жителя. Подсчитайте общее число жителей родившихся 1958г.



Вы находитесь на странице вопроса "Переписать,", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.