Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

дан массив из 85 целых чисел. Получить массив из 84 чисел, состоящий из элементов X i -X (i+1).

5-9 класс

Komogorseva321 01 окт. 2014 г., 14:28:08 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Rom4155
01 окт. 2014 г., 16:42:06 (9 лет назад)

var arr: array [1..85] of integer;
res: array [1..84] of integer;
k: integer;
begin
for k := 1 to 85 do begin
arr[k] := random(100);
end;
for k := 1 to 84 do begin
res[k] := arr[k] - arr[k + 1];
writeln(res[k]);
end;
end.

+ 0 -
Medinaleroeva
01 окт. 2014 г., 18:16:27 (9 лет назад)

program z9;
uses crt;
var
a:array [1..85] of shortint;
i:shortint;
begin
clrscr;
writeln('Данный массив');
for i:=1 to 85 do begin
a[i]:=random(50--50+1)+-50; {- заполнение массива случайным образом, числами от -50 до 50}
write(a[i]:4); {- вывод этих чисел на экран}
end;
writeln;
writeln('Полученный массив');
for i:=1 to 84 do begin
a[i]:=a[i]-a[i+1]; {Вычетание из элемента i, элемента i+1}
write(a[i]:4); {- вывод полученных чисел на экран}
end;
readkey
end.

Ответить

Другие вопросы из категории

Пожалуйста помогите решить задачу.

Информационный объем сообщения содержит 1024 символов составляет 1Кбайт.Каким количеством бит кодируется каждый символ этого сообщения?
варианты решения
1.32
2.16
3.8.
4.4
напишите решени

Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3. Программа получает на вход количество чисел в

последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число – сумму чисел, кратных 3. входные данные:3,12,25,9 выходные 21

Читайте также

1)Задан массив из 11 целых чисел. Найти сумму элементов массива, кратных 5 2)Задан массив из 11 целых чисел. Посчитать количество нечётных

элементов массива.

3)задан массив из 9 целых чисел.Вывести на экран чётные элементы

1. Разработать схему алгоритма, который вводит массив из N целых

чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел.

2. Разработать схему алгоритма, который вводит массив из N целых чисел и выводит на экран элементы с чётными номерами. Протестировать алгоритм на произвольных массивах размерностью 5 и 8 элементов.

3. Разработать схему алгоритма, который вводит массив из N целых чисел и выводит на экран элементы с нечётными номерами в обратном порядке. Протестировать алгоритм для следующих исходных данных:

а) 1 3 5 6 8 9

б) -1 4 6 2 4 6 8 6 9

P.S. Убедительная просьба написать решение целиком и до наступления ночи. Я являюсь дилетантом в Паскале, а эти три задачи являются моим домашним заданием по информатике на завтра.

Дан массив из N целых чисел a1,a2...,aN.Вам нужно проверить,есть ли в этом массиве три числа сумма которых равно нулю.

Формат входных данных

В певой строке входного файла содержится одно целое число n(1<=n<=200).Во второй строке находятся n целых чисел a1,a2...aN (-1000<=ai<=1000)-елементы массива.

Формат выходных данных

В единственной строке выходного файла выведите одно слово "YES",если в этом массиве есть три числа сумма которых равна нулю.Иначе выведите "NO".

1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива.

2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива.
3. Массив из 5 целых чисел вводится с клавиатуры в строку. Найти сумму элементов массива, стоящих на чётных позициях. Вывести исходный массив и полученную сумму.
4. Массив из 40 целых чисел из промежутка [10,90] задается с помощью генератора случайных чисел. Найти сумму элементов массива, кратных n . Вывести исходный массив и полученную сумму.
Помогите кто в чем может.

1). Дан массив из n элементов (n >= 4). Подсчитать среднюю арифметическую второго и предпоследнего элемента массива.

2). Дан массив из n элементов. Написать программу подсчитывающую произведение элементов массива.



Вы находитесь на странице вопроса "дан массив из 85 целых чисел. Получить массив из 84 чисел, состоящий из элементов X i -X (i+1).", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.