Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Pascal abc.

5-9 класс

Дан одномерный массив (вводится с клавиатуры).
Преобразовать массив таким образом, чтобы сначала располагались все элементы равные 0, а потом все остальные.

Sergeevna2112 15 февр. 2017 г., 4:08:35 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ПростоЗашла
15 февр. 2017 г., 5:32:53 (7 лет назад)

Program Massiv;
Const n = 5;
Var a: Array [1..n] of Integer;
tmp, c, i: Integer;
Begin
WriteLn('Введите ', n, ' чисел через пробел');
For i := 1 To n Do
Read(a[i]);
c := 1;
For i := 1 To n Do
If a[i] = 0 Then
Begin
tmp := a[c];
a[c] := a[i];
a[i] := tmp;
c := c + 1;
End;
WriteLn('Результат:');
For i := 1 To n Do
Write(a[i], ' ');
ReadLn;
End.  

Ответить

Другие вопросы из категории

Компьютер состоит из устройств, выполняющих некоторые функции мыслящего человека. Проведите аналогию между человеком и компьютером и заполните

таблицу.Органы человека: органы чувств, мозг, мозг, органы речи и опорно-двигательной системы. Информационный процесс: приём (ввод) информации, хранение информации, обработка информации, передача (вывод) информации. Устройства компьютера......... Пожалуйста, помогите!

помогите решить задачи по информатике

№1 ,сколько килобайтов содержится в4096 битах ?
№2, сколько байтов содержится в одном мегабайте?
№3 ,сколько килобайтов содержатся в30720 битах?
№4 одна тетрадь содержит262144 символов,сколько ,это в мегабайтах?
№5 можно ли поместить файл размером0,35 гигабайт на носитель, на котором свободно 365000 килобайт?подробное решение заранее спасибо!!!

Читайте также

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC.

Составить программу,которая выводит на экран сумму нечетных чисел от 1 до 30 в Pascal ABC.


1) дано четырёхзначное число. вывести максимальную и минимальную цифру. pascal abc

2) дано четырёхзначное число. Что больше: произведение цифр числа или их утроенная сумма. pascal ABC

Я работаю в прграмме Pascal ABC

Вот проверьте здесь гдето ошибка
program abc;
var a,b,c:integer;
begin;
write ('Длина равна=')
read(a);
write ('Ширина равна=')
read(b);
c:=a*b
write ('Площадь='c');
readln;
end.
Мне показало что в строке

Очень срочно. даю 100 пунктов. Pascal ABC. Если не сдам, будет 3 за четверть(((((((((((((( Написать программу, которая

сортирует массив ПО УБЫВАНИЮ и ищет в нем элемент, равный X (это число вводится с клавиатуры). Использовать двоичный поиск.



Вы находитесь на странице вопроса "Pascal abc.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.