Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Задача 1 Определить кол-во цифр в числе .

5-9 класс

Задача 2 Напечатать те натуральные числа квадрат которых не превышает n .
Задача 3 Найти первое натуральное число куб которого больше n .

Urallist 17 марта 2017 г., 22:15:11 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
123Аделина
17 марта 2017 г., 23:22:15 (7 лет назад)

var
  a, c : integer;
begin
  read (a);
  c := 0;
  while a > 0 do
  begin
    c := c + 1;
    a := a div 10;
  end;
  write (c);
end.

var
  i, n : integer;
begin
  read (n);
  for i := 1 to trunc (sqrt(n)) do
    write (i, ' ');
end.

var
  n, i : integer;
begin
  i := 1;
  while i*i*i <= n do
    i := i + 1;
  writeln (i);
end.

Ответить

Читайте также

Язык программирования Бейсик Здравствуйте. Кто может найти ошибку в моем решении задачи: "Напишите программу, которая находит кол-во

чисел, кратных 3, но не кратных 6, в последовательности заданных чисел. Программа получает на вход целые числа, кол-во введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность). Кол-во чисел не превышает 1000. Введенные числа по модулю не превышают 30000."

Решение:

10 CLS

20 FOR I=1 TO 1000

30 INPUT "Введите число";A(I)

40 IF A(I)=0 THEN M=I AND 60

50 NEXT I

60 FOR I=1 TO M

70 IF A(I) MOD 3 = 0 AND A(I) MOD 6 <>0 THEN S=S+1

80 NEXT I

0 PRINT S

100 END

Заранее спасибо

Задачи на кол-во информации)

1. Определите информационный объем текста в кавычках. Кавычки не учитывать: "Приучайтесь думать точно!"
2. На дискете помещается 1,4 Мб информации. Сколько дискет может заменить один жесткий диск, емкостью 420 Мб?
3. Сколько необходимо памяти (в Мб), чтобы сохранить картинку, которую мы видим на экране, если про монитор известно: кол-во точек 800*1200, кол-во цветов - 521?
4. а) в следующих записях проставьте знаки отношений:
3,2 Гбайта 4000 Мб
7 байт 55 бит
8150 байт 8 Кб
б) дополните равенства
9 байтов=___битам
20 Мбайтов=___Кб
5. Информация передаётся со скоростью 3 Кб/сек. Какой объем информации будет передан за 20 минут? Ответ дать в Мб.

1.Какое кол-во информации получит Миша после броска кубика с 16 гранями?

2.Играя в игру "Угадай число" было получено 6 бит информации. Каково было кол-во возможных событий?
3. Маша переехала в многоэтажный дом, и сообщение о том,что она живет на 24 этаже,несет 5 бит информации.Сколько этажей в доме?



Вы находитесь на странице вопроса "Задача 1 Определить кол-во цифр в числе .", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.