Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дан массив из чисел N.Определить каких элементов в массиве больше:отрицательных или положительных

10-11 класс

Alina1105 24 окт. 2014 г., 2:41:29 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Margocha1801
24 окт. 2014 г., 3:35:58 (9 лет назад)

var a:array[1..1000] of real;
i,n,ko,kp:integer;
begin
write('Введите количество элементов массива n= '); readln(n);
for i:=1 to n  do
read (a[i]);
for i:=1 to n  do
write(a[i],' ');
ko:=0; kp:=0;
for i:=1 to n do
if a[i]>0 then kp:=kp+1 else if a[i]<0 then ko:=ko+1;
if ko>kp then writeln ('Отрицательных элементов больше чем положительных')
else if ko<kp then writeln ('Положительных элементов больше чем отрицательных')
else writeln ('Количество положительных и отрицательных элементов равны');
end.

+ 0 -
Lekhapetrov86
24 окт. 2014 г., 4:15:56 (9 лет назад)

какой язык?

+ 0 -
Элеанор8542
24 окт. 2014 г., 7:15:20 (9 лет назад)

pascal

Ответить

Другие вопросы из категории

погогите пж

срочноооо

Сколько раз выполнится тело цикла в каждом фрагменте программы?

1. For i :=1 to 7 do S := S + i * i;
2. For x := -3 to 5 do 5 do K := K+ABS(X);
3. For a := 10 downo 2 do P :=P*a;
4. For i := 2 to 6 do
begin
K:=K+1;
S:=K+i;
end;

Сколько раз выполнится тело цикла, и чему будут равны значения встречающихся в программе переменных после выполнения каждого фрагмента программы?

5. i :=2; S:=0;
While S<0 do begib S:= S+i; i:+2; end;

6. x:=1 ; S:=10 ;
While x <=10 do x:=x*2 ;
S:= S+x

7. a:=0; S:=0 ;
While a> 0 do S :=S +a;
a:=a+1;

8 . a:=1;
Repeat
R := 2*a;
a:= a+1 ;
until R < 1;

9. a:=1; b:=1;
While a+b < 8 do begin a :=a+1; b := b+2 end;
S := a+b;

10. S:=0; P:= 10; k:= 1;
Repeat
S:= S+k*k;
k :=k+2;
until S > P;

11. For i :=2 to 6 do begin
K:= K+1; S:= K+i;
end;

12. for i:= 1 to 4 do S :=S+i*i; S: S*2;

Помогите пожалуйста!! я не могу понять что от меня хотят!!

Цель работы – получение навыков по проектированию информационных систем, и реализация их с помощью баз данных на основе системы управления базами данных MS Access.
БД «Учет движения транспортных потоков со склада» Генеральный список полей:Гаражный номер машины, государственный номер машины, адрес движения, расстояние в км, стоимость за 1 км, время выезда со склада, дата выезда со склада.Примечание. Запросы составить с условием отбора (по гаражному номеру, дате выезда со склада); с расчетом размера стоимости пробега; групповые расчеты для определения доходов с одной машины; групповые расчеты для определения доходов по месяцам и за год в целом.

вычислите значение выражения:

int(6,9)

Определите, может ли кирпич, имеющий форму прямоугольного параллелепипеда с ребрами a,b,c, пройти через прямоугольное отверстие со сторонами х и y (при это

м стороны параллелепипеда параллельны сторонам отверстия). Считать, что при равенстве размеров отверстия и кирпича, кирпич не может пройти в отверстие.

Читайте также

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от 0 до 100. Напишите программу, которая позволит найти сумму

двузначных элементов массива, которые не оканчиваются на 3. №2. Дан массив из 100 элементов. Каждый элемент может принимать целочисленные значения от 1 до 500. Напишите программу, которая позволит найти и вывести минимальное значение среди элементов массива, которые делят максимальное значение элементов массива без остатка.

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от -100 до 100. Напишите программу, которая позволит

подсчитать среднее арифметическое положительных элементов массива, которые кратны первому элементу массива. №2. Дан массив из 40 элементов. Каждый элемент может принимать целочисленные значения от 0 до 200. Напишите программу, которая позволит найти наиболее часто встречающийся элемент массива

на языке паскаль 1)дан массив натуральных чисел найдите сумму всех его элементов 2)вычислить количество положительных чисел

среди 10 элементов вещественного массива

3)заполнить массив из n целых чисел.выяснить какое число встречается раньше-положительное или отрицательное.

4)в целочисленном массиве есть отрицательные элементы.вывести номера этих элементов

1)дан массив натуральных чисел найдите сумму всех его элементов 2)вычислить количество положительных чисел среди 10 элементов вещественного

массива

3)заполнить массив из n целых чисел.выяснить какое число встречается раньше-положительное или отрицательное.

4)в целочисленном массиве есть отрицательные элементы.вывести номера этих элементов



Вы находитесь на странице вопроса "Дан массив из чисел N.Определить каких элементов в массиве больше:отрицательных или положительных", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.