Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

упорядочить по возрастанию массив целых чисел a1...an используя алгоритм сортировки выбором

10-11 класс

Mosescole 06 нояб. 2014 г., 20:36:10 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Зимка
06 нояб. 2014 г., 22:58:48 (9 лет назад)

const
N = 15;
var
a: array[1..N] of integer;
i, j, tmp: integer;
begin
for i := 1 to N do begin
a[i] := random(50);
write(a[i], ' ');
end;
writeln;

for i := 1 to N - 1 do
for j := 1 to N - i do
if a[j] > a[j+1] then begin
tmp := a[j];
a[j] := a[j+1];
a[j+1] := tmp
end;

write('По возрастанию: ');
for i := 1 to N do
write(a[i], ' ');
end.

Ответить

Другие вопросы из категории

На перекрестке произошло дорожно-транспортное путешествие, в котором участвовали автобус(А), грузовик(Г), легковой автомобиль(Л) и маршрутное такси(М).

Свидетели происшествия дали показания инспектору ГИБДД. Первый свидетель считал, что первым на перекресток выехал автобус, а маршрутное такси было вторым. Другой свидетель полагал, что последним на перекресток выехал легковой автомобиль, а вторым был грузовик. Третий свидетель уверял, что автобус выехал на перекресток вторым,а следом за ним - легковой автомобиль. В результате оказалось, что каждый из свидетелей был прав только в одном из своих утверждений. В каком порядке выехали машины на перекресток? В ответе перечислите подряд без пробелов первые буквы названий транспортных средств в порядке их выезда на перекресток, например АМЛГ. ( Пожалуйста, будьте добры с решением ;)

Читайте также

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .

Для упорядочивания по возрастанию массива целых чисел из 20 элементов (номера элементов начинаются с 0) начинающий программист написал следующий фрагмент

программы:
For i:=1 to 100 do
For j:=0 to 17 do
If a [j] > a [j+2] then
Begin
T := a [j]; a [j] := a [j+2]; a [j+2] := t
End;
Чему станет равен элемент массива с номером 17, если в начале работы фрагмента в массиве находились числа от 20 до 1 в порядке убывания?

Помогите пожалуйста!

массив целых чисел из 10 элементов заполнить случайным образом. упорядочить массив по возрастанию. подсчитать количество и произведение элементов массива, больших 20 и меньших 50, вывести полученный результат

Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом

массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию

Сортировка массивов по возрастанию и по убыванию. Массив задается от

датчика случайных чисел random(). Сортировать один и тот же исходный
массив и по убыванию и по возрастанию значений элементов.



Вы находитесь на странице вопроса "упорядочить по возрастанию массив целых чисел a1...an используя алгоритм сортировки выбором", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.