Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Найти сумму всех целых чисел больше -50, но меньше 200, которые кратны 5(делятся на 5). Напишите программу, пожалуйста.

5-9 класс

викуся102003 24 окт. 2016 г., 15:57:05 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Eleonorafominova
24 окт. 2016 г., 18:37:47 (7 лет назад)

program
project1;
uses
crt,math;
constn=10;
var  s:real;  i:byte;  a:array [1..10] of integer;
begin 
 for i:=1 to n do
  begin 
 writeln('vvedite ',i,' cifru');readln(a[i]); 
 end; 
 for i:=1 to n do 
begin 
 if ((a[i]>-50) and (a[i]<200) and ((a[i] mod 5) = 0)) then  s:=s+a[i]; 
end; 
writeln('summa vseh: ',s:2:2); 
readln;
end.

Ответить

Читайте также

Даны два целых числа А и В (А < В) . Найти произведение всех целых чисел от А до В включительно.

Входные данные: ввести два целых числа А,В (1 <=А,В<=10).
Входные данные: вывести произведение всех целых чисел от А до В включительно.

For4. Дано вещественное число — цена 1 кг конфет. Вывести стоимость 1, 2, …, 10 кг конфет. For7. Даны два целых числа A и

B (A < B). Найти сумму всех целых чисел от A до B включительно.

Помогите составить программу решения задачи в паскаль АВС.

Даны два целых числа А и В (А меньше В). Найти сумму всех целых чисел от А до В включительно.



Вы находитесь на странице вопроса "Найти сумму всех целых чисел больше -50, но меньше 200, которые кратны 5(делятся на 5). Напишите программу, пожалуйста.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.