Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Дан текст без знаков препинания. Между словами может быть только 1 пробел. Определить какой процент слов в тексте сожержит хотя бы 1 букву "d".

10-11 класс

Falen58 21 нояб. 2013 г., 16:56:29 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Galyawog
21 нояб. 2013 г., 18:17:14 (10 лет назад)

#include <iostream>
using std::cout;
using std::cin;
using std::endl;
using std::fixed;
#include <cstring>
using std::strcpy;
#include <iomanip>
using std::setprecision;

int main()
{
    char s[100], temp[100];
    int counter = 0, counter1 = 0;

    cout << "Enter the string: ";
    cin.getline(s, 100);

    strcpy(temp, s);

    //Определяем общее количество слов
    //и количество слов с буквай d
    char *ptr = strtok(temp, " ");
    while(ptr)
    {
        for(int i = 0; *(ptr + i) != NULL; i++)
        {
            if(*(ptr + i) == 'd')
            {
                counter1++;

                break;
            }
        }

        counter++;

        ptr = strtok(NULL, " ");
    }

    cout << setprecision(2) << fixed << (counter1 * 100 / double(counter)) << '%' << endl;

    return 0;
}

Ответить

Другие вопросы из категории

помогите сделать в паскале!

Запросить с клавиатуры координаты точки (X, Y) и горизонтального отрезка прямой (Xn, Xk, Yn) и определить, лежит точка на отрезке прямой или нет. Сообщение об этом вывести на экран. Подсказка. Если координата Y точки не равна координате Y прямой, то НЕ лежит, если координата Х точки не находится в пределах между Хn начала и Хk конца прямой, то точка НЕ лежит на прямой.

помогите пожалуйста!

Читайте также

Решите головоломку.Если в слове А его вторую половину, буквы которой образуют слово В, заменить на слово С, то получится слово Д. Причем: А - фрагмент

оперативной памяти размером в 16 байтов; В – конечное число точек на плоскости, соединённых отрезками кривых линий; С – единица измерения расстояния; Д – аргумент или результат процедуры.В ответе запишите найденные слова: сначала А, затем, В, С и Д, через один пробел, без знаков препинания.

В алфавите некоторого языка всего 4 буквы, слова в этом

языке состоят точно из 5 букв. Какое максимальное количество слов может быть в
этом языке?

Для кодирования некоторой последовательности, состоящей из букв А, Б, В, Г и Д, решили использовать неравномерный двоичный код, позволяющий

однозначно декодировать двоичную последовательность, появляющуюся на приёмной стороне канала связи. Использовали код: А–1, Б–000, В–001, Г–011. Укажите, каким кодовым словом должна быть закодирована буква Д. Длина этого кодового слова должна быть наименьшей из всех возможных. Код должен удовлетворять свойству однозначного декодирования. 1) 00 2) 01 3)11 4) 010



Вы находитесь на странице вопроса "Дан текст без знаков препинания. Между словами может быть только 1 пробел. Определить какой процент слов в тексте сожержит хотя бы 1 букву "d".", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.