Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

среди вводимых трёх чисел найти разность наибольшего и наименьшего

5-9 класс

VladDeev 22 окт. 2016 г., 23:10:08 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Rabelde98
23 окт. 2016 г., 1:24:50 (7 лет назад)

var a1,a2,a3,max,min,q:integer;
begin
read (a1,a2,a3);
if a1<a2 and a1<a3 then min:=a1;
if a2<a1 and a2<a3 then min:=a2;
if a3<a2 and a3<a1 then min:=a3;
if a1>a2 and a1>a3 then max:=a1;
if a2>a1 and a2>a3 then max:=a2;
if a3>a2 and a3>a1 then max:=a3;
q:=max-min;
write (q);
end.

Ответить

Другие вопросы из категории

Сформируйте массив из 10 целых элементов случайным образом на отрезке [0;50]. Определите минимальный элемент массива и его индекс. Выведите на экран

исходный массив в одну строку через пробел, а минимальный элемент массива и его индекс – в столбик.

Читайте также

1.Дан массив целых чисел, найти среднее арифметическое всех элементов массива.

2. Дан массив целых чисел,найти количество отрицательных элементов массива.
3. Дан массив целых чисел,найти количество чётных чисел в массиве.

Турбо паскаль

Среди всех трехзначных чисел найти те у которых первая цифра равна трем.

Кто-нибудь кто хорошо разбирается в Pascal ABC,помогите,пожалуйста! 1.Нарисовать круг, разделённый на N одинаковых частей, окрашенных в разный цвет.

Количество частей N вводится с клавиатуры. 2.Нарисовать пирамиду из разноцветных прямоугольников.Количество прямоугольников вводится с клавиатуры. 3.С клавиатуры вводятся целые числа, пока не встретится ноль (ноль служит только для ограничения ввода и в дальнейших подсчётах не участвует) Вычислить произведение максимального и минимального числа. 4.С клавиатуры вводятся целые числа, пока не встретится ноль (ноль служит только для ограничения ввода и в дальнейших подсчётах не участвует). Известно, что среди первых двух чисел нуля нет. Найти сумму двух наибольших чисел. 5.С клавиатуры вводятся целые числа, пока не встретится ноль (ноль служит только для ограничения ввода и в дальнейших подсчётах не участвует). Известно, что среди первых трех чисел нуля нет. Найти среднее арифметическое трёх наименьших чисел.



Вы находитесь на странице вопроса "среди вводимых трёх чисел найти разность наибольшего и наименьшего", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.