Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

1. PASCAL. Даны три точки A(x1,y1), B(x2,y2), C(x3,y3). Написать программу, определяющую, которая из точек находится ближе к началу координат.

10-11 класс

Alina30303 10 дек. 2016 г., 9:41:26 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
TaniaVoronkova
10 дек. 2016 г., 11:57:10 (7 лет назад)

Проверено - работает на Паскаль АВС:

 

Program kovyarovsany;
var
  x1,y1,x2,y2,x3,y3:integer;
  d1,d2,d3:real;
begin
  write ('X1 = ');readln(x1);
  write ('Y1 = ');readln(y1);  
  write ('X2 = ');readln(x2);
  write ('Y2 = ');readln(y2);
  write ('X3 = ');readln(x3);
  write ('Y3 = ');readln(y3);  
  d1:=sqrt(x1*x1+y1*y1);
  d2:=sqrt(x2*x2+y2*y2);
  d3:=sqrt(x3*x3+y3*y3);
  if (d1=d2) and (d1=d3) then
      writeln ('Все три точки на одинаковом расстоянии от начала координат ')
    else
    if (d1=d2) and (d1<d3) then
      writeln ('Точка 1 и точка 2 на одинаковом расстоянии от начала координат ')
    else
      if (d2=d3) and (d2<d1) then
        writeln ('Точка 2 и точка 3 на одинаковом расстоянии от начала координат ')
      else
        if (d1=d3) and (d1<d2) then
          writeln ('Точка 1 и точка 3 на одинаковом расстоянии от начала координат ')
        else
          if (d1<d2) and (d1<d3) then
             writeln ('Точка 1 ближе всех')
          else
            if (d2<d1) and (d2<d3) then
              writeln ('Точка 2 ближе всех')
            else
               writeln ('Точка 3 ближе всех');
end.

Ответить

Другие вопросы из категории

разработать программу на языке паскаль: 1) из массивов вещественных чисел А и В сформировать массив С, записав в него элементы массивов А и В, которые не

содержат "семерок" в восьмеричном представлении 2) в матрице целых чисел А (n.n) упорядочить те строки , в которых диагональные элементы не содержат семерок. ПОМОГИТЕ РЕШИТЬ ЛИБО 1 ЛИБО 2 ЗАДАЧУ

Необходимо написать программу на Паскале.

Условие задачи:
Составить программу формирования двумерного массива из предложенного одномерного так, чтобы первая строка нового массива содержала четные по номеру элементы исходящего массива, а вторая - нечетные. Предусмотреть случай нечетного количества элементов массива.

Например, если мы вводим такой одномерный массив 2 5 1 6 9 2, то должно вывести так:
5 6 2
2 1 9

А если количество элементов одномерного массива нечетное, например 2 5 1 6 9 2 4 то так:
5 6 2 0
2 1 9 4

Помогите пожалуйста, заранее благодарен!


Читайте также

Дано задание "Составьте программу, определяющую, лежит ли точка с

указанными координатами X, Y на окружности радиуса R с центром в
начале координат." я её составил но почему у меня всегда получается что точка не лежит на окружности хотя она лежит. Может я где то ошибся ?

var


x,y,r:integer;


Begin


Write('Введите координату X: ');


Readln(x);


Write('Введите координату Y: ');


Readln(y);


Write('Введите длину радиуса R: ');


Readln(r);


If (sqr(x)+sqr(y))=r


then writeln('Точка лежит на
окружности!')


Else writeln('Точка не лежит на
окружности!');




End.



Вы находитесь на странице вопроса "1. PASCAL. Даны три точки A(x1,y1), B(x2,y2), C(x3,y3). Написать программу, определяющую, которая из точек находится ближе к началу координат.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.