Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

вычислить Y в зависимости от x,введенного с клавиатуры Y=( х2,если х>0

5-9 класс

х+1,если х<=0
2 задача - вычислить Y в зависимости от x,введенного с клавиатуры (12,5*2,если -1<=х<0
х-1,если х<-1
12х,если х>0

Ivuts183 03 июня 2014 г., 7:22:24 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Юляша127
03 июня 2014 г., 8:33:29 (9 лет назад)

Первая:
var
x,y:integer;
begin
writeln('Vvedite x');
readln(x);
if x>0 then
 y:=sqr(x)
else
 y:=x+1;
writeln(y);
end.
Вторая 
var
x:integer;
y:real;
begin
writeln('vvedite x');
readln(x);
if (x<0) and (x>=-1) then
 y:=12.5*2
else 
 if x<-1 then
 y:=x-1
else
 y:=12*x;
writeln(y);
end.

Ответить

Читайте также

составьте программу которая а)выполняет операцию сцепления трех введенных с клавиатуры символов б)выполняет операцию сцепления трех введенных с

клавиатуры символов и выводит результат сравнения на экран. например 'a'<'б', 'д'='д, 'я'>'ы' в) выполняет сравнение двух введенных с клавиатуры символов и выводит их на экран в порядке вохрастания их кодов

1. Написать программу, которая спрашивает «Который час?» и, в зависимости от введенного времени, выводит на экран приветствие: «Доброе утро», «Добрый

день», «Добрый вечер», «Спокойной ночи».
2. Составьте программу, которая вычисляет оптимальный вес пользователя, сравнивает его с реальным весом и выдает рекомендации о необходимости поправиться или похудеть. Оптимальный вес вычисляется по формуле: рост (в сантиметрах) – 100.
Помогите решить 2 задачи

Даны числа a,b,c. Составить программу, выводящую на экран сообщение, в зависимости от того какой треугольник можно построить с такими длина сторон:

равносторонний,равнобедренный или какой либо другой.

Вот ещё одна

Составить программу:Даны а,b,c-целые числа.Если они большн 0-вычислите сумму их квадратов;а если хотя бы одно из них четно-вычислите их сумму и произведение.

Пожалуйста ребят.



Вы находитесь на странице вопроса "вычислить Y в зависимости от x,введенного с клавиатуры Y=( х2,если х&gt;0", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.