Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

2. Дан числовой массив А, состоящий из п натуральных чисел. Определите количество элементов массива, которые больше заданного числа. (3 балла)

10-11 класс

Vovik78 18 авг. 2014 г., 17:27:12 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Девушка1с1той1улицы
18 авг. 2014 г., 20:22:16 (9 лет назад)

Program Free Pascal 2.6.0;

Uses crt;

const n = 5; // например 5

var A:array [1..n] of integer;

i,col:integer;

 

begin

clrscr;

 col:=0;   //  Кол-во элементов больших заданного изначально = 0

 for i:=1 to n do

   begin 

     read(A[i]);  // Заполняем массив произвольными числами

     if (A[i]>n) then col:=col+1;  // Если введенное число больше задонного (>5), то кол+1

   end;

writeln;  

writeln('Кол-во элементов больших заданного: ',col); 

readkey; 

end. 

  

Ответить

Читайте также

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.

срочно помогите решить! дам много пунктов!!! пожалуйста, зачет по информатике!! в qBasiq Вариант №

1

Дан массив целых чисел, состоящий из 20 элементов. Заполнить его с клавиатуры.

1. Найти:

- сумму элементов, имеющих нечетное значение;

- вывести индексы тех элементов, значения которых больше заданного числа А.

2. Определить, есть ли в данном массиве положительные элементы, кратные k (k вводить с клавиатуры).

ПАСКАЛЬ.1)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 1000.опишите на русском языке или на одном из

языков программирования алгоритм,позволяющий найти среднее арифметическое нечетных трехзначных чисел,записанных в этом массиве.если ни одного такого числа нет,нужно вывести сообщение об этом.
2)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 100.опишите на русском языке или на одном из языков программирования алгоритм,позволяющий найти и вывести произведение элементов массива,которые имеют четное значение и не оканчиваются на 0.

Pascal ABC

1. Дан двумерный числовой массив A состоящий из 35*35 элементов. Написать программу для нахождения количества значений элементов массива меньших среднего арифметического значения элементов массива.

2.Дан двумерный числовой массив A состоящий из 15*100 элементов. Написать программу для нахождения количества элементов массива делящихся на 13 без остатка.

дан целочисленный массив из 20 элементов. Элементы массива могут принимать целые числа от о до 10000 включительно. Опишите на естественном языке или на

одном из языков программирования алгоритм, позволяющий найти и вывести максимальное значение среди трехзначных элементов массива, оканчивающихся на 0



Вы находитесь на странице вопроса "2. Дан числовой массив А, состоящий из п натуральных чисел. Определите количество элементов массива, которые больше заданного числа. (3 балла)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.