Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Программа заполняет массив из 12 целых чисел случайными числами в диапазоне от -3 до 38. Программа находит максимальный элемент массива и выводит его

10-11 класс

на экран.

на паскале

Софкаааа 06 нояб. 2014 г., 7:12:16 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Zukovivan
06 нояб. 2014 г., 8:46:21 (9 лет назад)

Program one;
var a:array[1..12] of integer;
i,m:integer;
begin
m:=0;
for i:=1 to 12 do
begin
a[i]:=random(42)-3;
if a[i]>m then m:=a[i];
end;
writeln(m);
end.

Ответить

Другие вопросы из категории

помогите исправить ошибки.Масиви. Уплотнить линейный массив, удалив нули и сдвинув влево остальные элементы program

{ Уплотнить линейный массив удалив нули и сдвинув влево остальные элм.}

uses crt

var m,i,k:longint a:array[1..100]of longint

begin

clrscr

write('введите кол-во элм таблицы: ')redln(k)

for i=1 to k do

begin

write('a[',i,']=')redln(a[i])

end

m=0

for i=1 to k do

if a[i]=0 then inc(m)

elsey a[i-m]=a[i]k=k-m

for i=1 to k do write(a[i],' ')redln

end.

Помогите написать программу на Паскале.

В целочисленной матрице размером 10x10 найдите максимальное значение и индексы всех элементов, равных ему.

Выберите

вариант, в котором объемы памяти расположены в порядке возрастания

что делать в жизни ?

Читайте также

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.

Срочно! Помогите пожалуста! Нужно написать програмный код в турбо паскале! Заранее ОГРОМНОЕ СПАСИБО!! Заполнить массив из 10 элементов

случайными числами в интервале от 0 до 4 и вывести номера всех элементов, равных X.

Пример:

Исходный массив:

4 0 1 2 0 1 3 4 1 0

Что ищем? 0

A[2], A[5], A[10]

на языке паскаль 1)дан массив натуральных чисел найдите сумму всех его элементов 2)вычислить количество положительных чисел

среди 10 элементов вещественного массива

3)заполнить массив из n целых чисел.выяснить какое число встречается раньше-положительное или отрицательное.

4)в целочисленном массиве есть отрицательные элементы.вывести номера этих элементов

1)дан массив натуральных чисел найдите сумму всех его элементов 2)вычислить количество положительных чисел среди 10 элементов вещественного

массива

3)заполнить массив из n целых чисел.выяснить какое число встречается раньше-положительное или отрицательное.

4)в целочисленном массиве есть отрицательные элементы.вывести номера этих элементов

Дана строка , в которой содержится осмысленное текстовое сообщение. Слова сообщения разделяются В заданном формате дд- целое число из диапазона от 1 до

31, мм - целое число из диапазона от 1 до 12, а гг - целое число из диапазона от 1 до 2020 (если какая-то часть формата нарушена, то данная подстрока в качестве даты не рассматривается.) Заменить каждую дату сообщения на дату следующего дня. Написать программу на Паскале. Сроооооооооооооочнооо. Пооожалуйста.....

10-11 класс информатика ответов нет


Вы находитесь на странице вопроса "Программа заполняет массив из 12 целых чисел случайными числами в диапазоне от -3 до 38. Программа находит максимальный элемент массива и выводит его", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.