Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

паскаль,1) вывести все четные числа от 1 до 15

10-11 класс

2)вывести на экран числа от 2 до 9 с шагом 0,2

Poreu 22 июля 2014 г., 11:29:29 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kristimax
22 июля 2014 г., 13:54:52 (9 лет назад)

var
  i: integer;

begin
  i := 2;
  while i < 15 do
  begin
    write(i:3);
    i := i + 2
  end;
  writeln
end.

Тестовое решение:
  2  4  6  8 10 12 14

var
  p: real;

begin
  p := 2;
  while p < 9.01 do 
  {Нельзя задавать ровно 9 из-за накопления ошибок шага 0.2}
  begin
    write(p:4:1);
    p := p + 0.2
  end;
  writeln
end.

Тестовое решение:
 2.0 2.2 2.4 2.6 2.8 3.0 3.2 3.4 3.6 3.8 4.0 4.2 4.4 4.6 4.8 5.0 5.2 5.4 5.6 5.8 6.0 6.2 6.4 6.6 6.8 7.0 7.2 7.4 7.6 7.8 8.0 8.2 8.4 8.6 8.8 9.0




Ответить

Другие вопросы из категории

С помощью электронных таблиц смоделировать поведение следующей системы.

Рассматривается популяция простейших организмов, генетический код которых имеет информационную емкость 6 битов. Передача на-следственных признаков происходит по следующему правилу: четные (но-мера мест слева направо) гены наследуются от деда, а нечетные – от отца. Для удобства идентификации этих организмов будем использовать сле-дующий прием - рассматривая цепочку числового представления генов как шестизначное двоичное число, каждой особи можно поставить в соответст-вие его десятичное значение.

Пример
Представитель поколения: «Дед» «Отец» «Сын»
Двоичный код: (011010) (000111) (010010)
Десятичный код: 26 7 18

Смоделировать последовательность особей этой популяции с помо-щью электронных таблиц. При этом, исходные данные (два первых члена последовательности) задаются в виде целых десятичных чисел.
Рассчитать последовательность длиной в 6 поколений, если первые два имеют десятичные коды 45 и 17, соответственно.
Записать полученную таблицу в режиме отображения формул.

Помогите пожалуйста 10
Решите, пожалуйста. Буду очень благодарен!

Даны x, y, c. Вывести их на экран в порядке возрастания.

Читайте также

№1 Вывести на экран квадраты чисел от 1 до n. №2 Вывести на экран таблицу умножения от 1 до 10

числа n.

№3

Вычислить значение факториала n!

№4

В диапазоне от 1 до n вывести все четные числа на экран.

№5

Найти количество чисел, которые делятся на 3 и 5, из диапазона от 1 до n.

1)вывести все натуральные числа от 100 до 200 кратные 5

2) подсчитать общее кол-во делителей числа 100

Для кодирования номеров автомобилей принята следующая структура данных: Номер региона (двузначное число от 00 до 99), серия (комбинация из трех букв из

набора «А, В, Е, К, М, Н, О, Р, С, Т, У, Х»), номер (трехзначное число от 000 до 999). При создании базы данных автомобильных номеров Петя решил хранить каждый номер в виде массива из 8 символов (два символа на номер региона, три символа на серию и три символа на номер), кодируя каждый символ с помощью однобайтной кодировки ASCII. Вася решил уменьшить объем хранимых данных и принял решение хранить каждый номер в виде трех чисел – одно число для номера региона, одно число для серии (представив все возможные серии в виде натуральных чисел) и одно число для номера. Каждое число Вася будет хранить отдельно, используя для его кодирования минимально возможное число бит. На сколько бит уменьшится объем памяти, необходимый для хранения одного произвольного номера, в варианте кодирования Васи по сравнению с вариантом кодирования Пети? В ответе укажите целое число.



Вы находитесь на странице вопроса "паскаль,1) вывести все четные числа от 1 до 15", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.