Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

составить программу которая заменяет все нечетные числа на 31 массив из 15 целых чисел формируется случайным образом в интервале [20;30]

10-11 класс

Ebel2000 15 февр. 2015 г., 1:27:30 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Zinaqareeva589
15 февр. 2015 г., 4:17:57 (9 лет назад)

Program Task;
Const n = 15;
Var a: Array [1..n] of Integer;
i: Integer;
Begin
    Randomize;
    For i := 1 To n Do
        a[i] := Random(30 - 20 + 1) + 20;
    WriteLn('Массив:');
    For i := 1 To n Do
        Write(a[i], ' ');
    WriteLn;
    For i := 1 To n Do
        If a[i] Mod 2 = 1 Then
            a[i] := 31;
    WriteLn('Результат:');
    For i := 1 To n Do
        Write(a[i], ' ');
    ReadLn;
End.

Ответить

Другие вопросы из категории

Для груп­по­вых опе­ра­ций с фай­ла­ми ис­поль­зу­ют­ся мас­ки имён

фай­лов. Маска пред­став­ля­ет собой по­сле­до­ва­тель­ность букв, цифр и
про­чих до­пу­сти­мых в име­нах фай­лов сим­во­лов, в ко­то­рых также
могут встре­чать­ся сле­ду­ю­щие сим­во­лы:

Сим­вол «?» (во­про­си­тель­ный знак) озна­ча­ет ровно один про­из­воль­ный сим­вол.

Сим­вол «*» (звёздоч­ка) озна­ча­ет любую
по­сле­до­ва­тель­ность сим­во­лов про­из­воль­ной длины, в том числе
«*» может за­да­вать и пу­стую по­сле­до­ва­тель­ность.

Опре­де­ли­те, какое из ука­зан­ных имён фай­лов удо­вле­тво­ря­ет маске:
?mur*r.?st

1) mur.lst
2) omurr.sst
3) omur.sts
4) mur.lst


последовательность: 4, 1, 9, 3, 7, 5, из всех чисел которые больше 4 вычесть 3 затем удалить из всей последоательности нечетные числа

Пожалуйста с решением

помогите пожалуйста на 2 вопроса ответить:

1)В системе счисления с некоторым основанием десятичное число 29 записывается в виде 41.Укажите это основание?
2)Укажите через запятую в порядке возрастания все основания системы счисления,в которых запись числа 24(в десятеричной системе счисления) оканчивается на 4.
Очень буду вам благодарна,заранее спасибо!!!!)

Читайте также

Составьте программу, которая заменяет все буквы "о" на символ "*" в строке s.

Использовать можно функции pos, length, copy, delete, insert.

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.

помогите коле и напишите программу или алгоритм которое находит все просые числа в диапазоне от m до N ВКлючительно

в задаче требуется написать программу которая по двум заданным числам находила бы в диапазоне между этими числами все простые числам где простое число которое имеет всего лишь два делителя то есть оно делится на единицу и на само себя и больше оно не на что не делиться например -3 7 11 помогите )) олимпиада по инфе )) даю максимум баллов ))



Вы находитесь на странице вопроса "составить программу которая заменяет все нечетные числа на 31 массив из 15 целых чисел формируется случайным образом в интервале [20;30]", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.