Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Даны три отрезка со сторонами a,b,c. Выяснить можно ли построить треугольник с данными сторонами, если - да, то переменной y присвоить значение 1,

5-9 класс

иначе - 0.

Mirrynka 03 дек. 2016 г., 19:35:28 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
PlayGround
03 дек. 2016 г., 22:03:02 (7 лет назад)

Из математики:
треугольник существует тогда и только тогда, когда длина одной стороны не превосходит суммы длин двух других сторон (неравенство треугольника). Т.е. необходимо провести три сравнения:

program qq;
uses crt;
var a, b, c, p:  integer;
begin
p:=0; // обнуляем переменную
writeln('Введите через пробел значения a, b и с');
readln (a, b, c);
if a<=(b+c) then
                    if b<=(a+c) then
                                        if c<=(b+a) then
                                                            p:=1; //если все условия
                                                                      //выполнены то треугольник
                            //существует. присваиваем переменной значение 1.  
writeln (p);
end.

Ответить

Другие вопросы из категории

Помогите пожалуйста решить!!!!))

Рассчитайте объем видеопамяти необходимой для хранения графического изображения занимающего весь экран монитора с разрешением 1024 на 768 и кол вом отображаемых цветов равным 16777216

Читайте также

Написать программу в паскалabc

Даны 3 числа. Определить, можно ли построить треугольник с указанными сторонами.

Треугольник со сторонами Даны длины 3-х отрезков. Из них можно составлять треугольники, соединяя отрезки концами. Нужно

сказать, можно ли получить таким способом равносторонний, равнобедренный или разносторонний треугольники.

Input

Со стандартного устройства ввода вводится через пробел 3 целых положительных числа, не превосходящих 10000 – длины отрезков.

Output

Нужно выдать на стандартное устройство вывода одно из следующих сообщений:

“Triangle is equilateral” – если треугольник равносторонний

“Triangle is isosceles” – если треугольник равнобедренный

“Triangle is scalene” – если треугольник разносторонний

“Triangle is invalid” – если треугольника не существует

Кавычки выводить не нужно.

Sample Input

100 60 80

Sample Output

Triangle is scalene



Вы находитесь на странице вопроса "Даны три отрезка со сторонами a,b,c. Выяснить можно ли построить треугольник с данными сторонами, если - да, то переменной y присвоить значение 1,", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.