Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дано целое число. Верно ли, что оно кратно 7 и содержит 3цифры? составьте программу и проверьте ее для указанных чисел сравнив результат работы программы

10-11 класс

с правильном результатом..
число правильный ответ
21 неверно
121 неверно
777 верно
-777 верно
ТОЛЬКО ПРОГРАММУ НАПИСАТЬ!

Ahmarashka74 25 янв. 2017 г., 0:39:10 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alex364
25 янв. 2017 г., 1:11:28 (7 лет назад)

var a:integer;
begin
writeln('Введите число');
readln(a);
if a<0 then a:=(-1)*a;
if (a mod 7 =0) and (a div 100>1)then writeln('Верно')
else writeln('Неверно');
end.

Ответить

Другие вопросы из категории

Составить программу в Паскале.

Вам дано три числа a,

Написать программу в Паскале!!!

Указание: Заполнить двумерный числовой массив И(8,8) случайными целыми числами в интервале [-60,60].Написать единую программу для всех задач,ответ каждой задачи выводить с новой строки.
Задача 1: Найдите среднее арифметическое отрицательных элементов 3 строки.
Задача 2: Обнулите элементы,имеющие четное значение и стоящие на побочной диагонали.
Задача 3: Создайте новый одномерный массив из элементов,имеющих значение больше -5.
Задача 4: Определите максимальный элемент массива в первом столбике.
Задача 5: Вычислить сумму элементов в каждой строке массива.

Читайте также

4 задачи: ввести натуральное число и определить, верно ли, что сумма цифр равна 10 (через repeat и until)//// ввести натуральное

число и определить, какие цифры встречаются несколько раз (через repeat и until)///

ввести целое число и найти сумму его цифр (через while)

ввести целое число и определить , верно ли, что в его записи есть две одинаковые цифры(через while)

всё через паскаль абс

дано натуральное число верно ли что это число четырехзначное

в паскале программу написать

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число

1.Дано натуральное число:

a) найти произведение цифр числа б) верно ли, что в данном числе нет данной цифры А (цифру А вводить с клавиатуры)
2. Найти все трехзначные числа, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, а при увеличении на 4 делятся на 5.
3.Из данного натурального числа удалить все цифры А (а вводятся с клавиатуры).

Написать программы в паскале и желательно блок-схему, но можно и без нее.
Помогите пожалуйста)

Всем привет! Помогите пожалуйста по информатике. Задача: ввести целое число и найти сумму его цифр. Пример: введите целое число:1234. Сумма цифр числа 1

234 равна 10. Задача: сумма цифр ввести целое число и определить верно ли, что в его записи есть 2 одинаковые цифры. Пример: введите целое число 1234 нет введите целое число 1224 да



Вы находитесь на странице вопроса "Дано целое число. Верно ли, что оно кратно 7 и содержит 3цифры? составьте программу и проверьте ее для указанных чисел сравнив результат работы программы", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.