Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дана следующая программа на языке Паскаль:

5-9 класс

Приведите примеры значений переменных x и y из программы ТАЗ при которых появляются ошибки переполнения.

Kkamenevanast 20 окт. 2013 г., 8:40:18 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
MatmanCooL
20 окт. 2013 г., 10:37:34 (10 лет назад)

Целочисленный тип integer определяет числа в диапазоне (-32768..32767)

Ответить

Читайте также

Помогите, пожалуйста, очень нужно! Срочно!:( 1) Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы

вычисления: а) y=x^10 б) y=x^15. Постараться использовать минимальное количество дополнительных переменных. 2) Дана сторона равностороннего треугольника. Найти площадь этого треугольника, его высоты, радиусы вписанной и описанной окружностей. Программу записать на языке Паскаль. 3) Дана величина А, выражающая объём информации в байтах. Перевести А в более крупные единицы измерения информации. Программу записать на языке Паскаль

Плиз срочно надо.1)Найдите правильную на языке паскаль запись выражения

19(16,3+7,7).а)19(16.3+7.7),в)19*(16.3+7.7).д)19(16,3+7.7).с)19*(16.3+7.7).2)Найдите правильную на языке паскаль записы выражения \frac{34,5+24,5}{15y}.а)34.5+24.5/15у в)(34.5+24.5)/15у с)(34.5+24.5)15*у.д)(34.5+24.5)/(15*у).3)Вычислите длину окружности и площадь круга одного и того же заданного радиуса R.4)Даны два числа.Найдите среднее арифметическое кубов этих чисел и среденее геометрическое модулей этих чисел.Два последних номера там нужно написать программу,программу присылать на листочке

дан фрагмент программы на языке паскаль for i:=1 to 5 do for j:=1 to 5 do if (i+j) mod 2 <> 0 then write (скрыть крол

ика);

если применить данный алгоритм к матрице заполненной кроликами то сколько кроликов останутся нескрытыми?

помогите, пожалуйста, решить задачу... написать программу на языке Паскаль Продав квартиру, вы получили 22000 долларов и

положили их в банк. Банк начисляет 18% в первый месяц, а каждый следующий - тоже 22%, но уже с общей суммы с учётом начисленных процентов. Сколько денег будет в банке на вашем счету через год? (Нестабильностью нашей экономической системы пренебрегаем)

Дана программа на языке Паскаль: program a3; var x, y, z: real; begin writeln (' Введите три числа'); readln (x, y,

z);

if (x<=y) and (y<=z) then begin x:=2*x y:=2*y; z:= 2*z

end

else

begin

x:= abs(x) y:= abs(y) z:= abs(z)

end

writeln( x, ' ', y, ' ', z)

end

Составьте блок-схему, соответствующую программе.

Что является результатом работы программы?



Вы находитесь на странице вопроса "Дана следующая программа на языке Паскаль:", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.