Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

ЭТО СРОЧНО ПОМОГИТЕ

10-11 класс

Напишите программу, которая ответит на вопрос:

Является ли треугольник со сторонами a, b, c равносторонним?
Является ли треугольник со сторонами a, b, c равнобедренным?
Существует ли треугольник со сторонами a, b, c?
Лежит ли точка с координатами a и b в первой координатной четверти?
Являются ли заданные числа b и c квадратом и кубом числа a?
ТРЕБОВАНИЯ:

Программа вводит три вещественных числа и выводит пять строк с ответами на каждый из вопросов 1-5.
ИМЯ ФАЙЛА С ПРОГРАММОЙ = ВАШЕЙ ФАМИЛИИ

Schastlivaya34 03 сент. 2014 г., 0:38:20 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Saiaslav
03 сент. 2014 г., 1:26:16 (9 лет назад)

укажу часть решения (на все, увы, нет времени, работать надо - и как бы вы меня не уговаривали, все же сделаю это на паскале, но если нужно будет - исправлю под плюсы):

1) Чтобы проверить, является ли треугольник равносторонним, нужно узнать, равны ли все его стороны:
if (a = b) and (b = c) then
writeln('TRUE')
else
writeln('FALSE');

2) У равнобедренного треугольника должны быть равны две стороны:
if (a =b) or (b = c) or (a = c) then
writeln('TRUE')
else
writeln('FALSE');

3) Для существования треугольника сумма любых его двух сторон должна быть больше третьей:
if (a + b > c) and (a + c > b) and (b + c > a) then
writeln('TRUE')
else
writeln('FALSE');

4) Тут всё просто, первая четверть это неотрицательные значения для осей абсцисс и ординат:
if (a >= 0) and (b >= 0) then
writeln('TRUE')
else
writeln('FALSE');

С последним разберешься сам, там тоже несложно. В единую программу, надеюсь, сможет восьмиклассник собрать части кода?

+ 0 -
здинь
03 сент. 2014 г., 2:50:51 (9 лет назад)

Комментарий удален

+ 0 -
Danilsadko
03 сент. 2014 г., 3:58:51 (9 лет назад)

Комментарий удален

+ 0 -
Elenka2001
03 сент. 2014 г., 5:36:01 (9 лет назад)

Комментарий удален

+ 0 -
Pashamazefaker
03 сент. 2014 г., 7:35:30 (9 лет назад)

Комментарий удален

+ 0 -
Knopkaа
03 сент. 2014 г., 9:47:24 (9 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

В таблице приведены запросы и количество найденных по ним страниц некоторого сегмента сети Интернет.

запрос найдено страниц ( в тысячах)
зубр & тур 5000

зубр 18000

тур 12000

Какое количество страниц ( в тысячах) будет найдено по запросу зубр / тур?
Решите задачу используя круги Эйлера.

ТЕМА 4. ТЕХНОЛОГИЯ ПРОГРАММИРОВАНИЯ В СРЕДЕ TURBOBASIC (QBASIC или TURBOPASCAL).

57.
Оператор определения функции пользователя.. ---- помогите на вопрос ответить или пояснения к данному вопросу

Читайте также

Помогите, это срочно!!!!!
Ребята,срочно помогите!)Даю 100 баллов.Составить алгоритм решения задачи на языке C++ . В отчете предоставить три программы с разными операторами

цикла (do ...while, while, for). В алгоритме и программе массивов не использовать.

Я здесь набросал все ,что мог, помогите доработать, написать до конца все эти операторы в одну программу,не получается.

#include <iostream>
#include <cstdlib>
#include <conio.h>
#include <math.h>

using namespace std;
int main()
{
float a,z,xn,xk,dx,R,max,min; float count=0,x;
a = 2.94;xn = 1.5;xk = 5.5;dx = 0.4;
while (xn <= xk)

for (x >= xn; x <= xk; x+=dx, dx = dx + 0.4)
{
do
{
z = a*pow((a*x*x*x*x*x*x*x/cos(a*a*a)+1,31),(1/5));
printf("X = %10f, Z = %10f \n", x, z);
dx = dx + 0.4;
}
while (x <= xk);
return 0;
}
{
max = x;min = z;
if (x > max) max = x;
if (z < max) min = z;
if (count > 2) count = 0;
if (count == 2) printf("X = %10f, Z = %10f \n", x, z);
count=0;
}
cout<<"max="<<max<<"\t min="<<min<<"\n";
cout<<"R="<<min-max<<"\n";
system("PAUSE");
return 0;
}

Срочно помогите как это решить?
ребят очень срочно помогите ;(


Вы находитесь на странице вопроса "ЭТО СРОЧНО ПОМОГИТЕ", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.