Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Написать программу, которая в зависимости от введенного количества минут (M <= 60) будет подставлять слово минута в нужном падеже

5-9 класс

Например, 25 минут

EdwardSleep 21 нояб. 2016 г., 9:17:58 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sergey19996
21 нояб. 2016 г., 12:02:48 (7 лет назад)

var

  M:byte;

begin

  write('M = '); readln(M);

  case M div 10 of

    1: writeln(M, ' минут');

    else

      case M mod 10 of

        0, 5..9: writeln(M, ' минут');

        1: writeln(M, ' минута');

        2..4: writeln(M, ' минуты');

      end;

  end;

end.

Ответить

Другие вопросы из категории

как программируется цикл с предусловием на паскале?

почему алгоритм вычисления N! должен быть циклическим ?
что такое математическая формализация задачи?

Пользователь находился в каталоге, который назывался ТЕКСТ. Сначала он поднялся на один уровень вверх, потом спустился на один уровень вниз, затем еще р

аз спустился на один уровень вниз. В результате пользователь оказался в каталоге, полное имя которого D:\ИВАНОВ\ТАБЛИЦЫ\ЗАРПЛАТА. Какой был полный путь к каталогу, в котором пользователь находился первоначально?

Читайте также

Помогите плиз срочно 1)Написать программу,которая спрашивает"Который час?" и,в зависимости от введенного времени,выводит приветствие:"Доброе

утро","Добрый день","Добрый вечер", "Спокойной ночи". 2)Написать программу,которая определяет,принадлежит ли точка с координатами (x,y)Заштрихованной области,ограниченной точками(x1,y1)(x2,y2).

Пожалуйста помогите решить желательно все или хотя бы одну (P.S. программа для программы Turbo Pascal) 1.Написать программу, которая предлагает

ввести 3 значное число и находит сумму его цифр.

2. Написать программу, которая предлагает ввести 3 значное число и меняет порядок цифр наоборот. (123- 321)

3.Написать программу, которая предлагает ввести три числа с клавиатуры, находит их сумму, произведение и среднее арифметическое.

1. Написать программу, которая спрашивает «Который час?» и, в зависимости от введенного времени, выводит на экран приветствие: «Доброе утро», «Добрый

день», «Добрый вечер», «Спокойной ночи».
2. Составьте программу, которая вычисляет оптимальный вес пользователя, сравнивает его с реальным весом и выдает рекомендации о необходимости поправиться или похудеть. Оптимальный вес вычисляется по формуле: рост (в сантиметрах) – 100.
Помогите решить 2 задачи

Паскаль абс 2 задачи 1)Написать программу выводящую на экран последовательность чисел от 1 до 10 через пробел в строчку.

2)Написать программу которая бы выводила на экран произведение нечетных чисел от 10 до 20.



Вы находитесь на странице вопроса "Написать программу, которая в зависимости от введенного количества минут (M <= 60) будет подставлять слово минута в нужном падеже", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.