Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Решите очень срочно! Заранее огромное спасибо! В Turbo Pascal. Вывести на экран все числа от 1 до N , у которых 4 делителя.

5-9 класс

Заранее спасибо!

K031199b 07 апр. 2017 г., 6:17:09 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Артур
07 апр. 2017 г., 6:34:43 (7 лет назад)

program green; uses crt; var n,i: integer; begin write('Please enter n'); read(n); for i:=1 to n do begin write(i:4); end; writeln; for i := 1 to n do if i mod 4 = 0 then begin write(i:4); end; readln; end

+ 0 -
Артур
07 апр. 2017 г., 6:39:04 (7 лет назад)

program green; uses crt; var n,i: integer; begin write('Please enter n'); read(n); for i:=1 to n do begin write(i:4); end; writeln; for i := 1 to n do if i mod 4 = 0 then begin write(i:4); end; readln; end.

+ 0 -
Sabina969
07 апр. 2017 г., 8:30:32 (7 лет назад)

program qdiv;

var

 j, s, i, N: integer;

begin

 readln(N);

 for i:=1 to N do begin

  s:=0;

  for j:=1 to i do if i mod j = 0 then s:=s+1;

  if s=4 then writeln(i);

 end;

end.

 

for j:=1 to i do if i mod j = 0 then s:=s+1 - если 1 и само число тоже считать делителями. Иначе писать

for j:=2 to i-1 do if i mod j = 0 then s:=s+1

Ответить

Другие вопросы из категории

1.напишите программу которая в последовательности натуральных чисел определяет сумму чисел кратных семи и оканчивающихся на один

количество не известно
2.напишите программу которая в последовательности натуральных чисел определяет количество чисел кратных пяти и оканчивающийся на ноль.

Укажите сходство и различие следующих пар объектов:

1.Перемещение по тексту с помощью клавиш управления курсором в режиме прокрутки(сходство и различие)
2.Режимы вставки и замены(сходство и различие)

помогите решить две задачи с помощью "паскаля"

1)Ученик выучил в первый день 5 английских слов ,а последующие дни он учил на два слова больше чем в предыдущие через сколько дней он выучит 250 слов?
2)Вычислить сумму и произведения натурального числа от 1 до 20.

1. Записать в системе счисления с основанием 234 число 235..

Будьте людьми, помогите!!!!!

Читайте также

Задание 4.Составте программу ,выводящую на экран числа от 1 до 10 , по одному числу в строке.

Задание 5.Дополните программу из задания 4 так , чтобы на экран выводились числа от 1 до 10,а также квадраты и кубы этих чисел в следующем виде:
1 1 1
2 4 8
3 9 27
... ... ...
10 100 1000

ПОМОГИТЕ ПОЖАЛУЙСТА,ЗАДАНИЕ 4 ПИСАТЬ НЕ НУЖНО !ПОСТАВЛЮ ЛУЧЩИЙ ОТВЕТ И "СПАСИБО"

Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!



Вы находитесь на странице вопроса "Решите очень срочно! Заранее огромное спасибо! В Turbo Pascal. Вывести на экран все числа от 1 до N , у которых 4 делителя.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.