Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Цикл с пост условием!! помогите

5-9 класс

Написать программу которая будет вводить целые числа до тех пор пока не будетвведён 0. Подсчитать количество положительных и отрицательных чисел.

Andreyodintsov 11 дек. 2013 г., 23:46:10 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ТыУлыбнись
12 дек. 2013 г., 2:20:38 (10 лет назад)

Var N,otr,pol:real; Begin Read(n); If n=0 writeln('error') else Repeat do Write(n);  If n mod 2=0 then pol:=pol+1 else otr:=otr+1;Read(n); Until n=0; Writeln('otr:',otr);Writeln('otr:',otr);End. 

Ответить

Читайте также

Составить программу вычисления суммы всех натуральных чисел меньше 100 и кратных b ( от1 до 100).

Нужно составить 1- с циклом с пред условием, 2 - с циклом с пост условием

в каком типе цикла тело цикла выполняется пока условие ложно?

А) цикл со счетчиком
Б) цикл с постусловием
В) цикл с предусловием
Г) цикл с рекурсией



Вы находитесь на странице вопроса "Цикл с пост условием!! помогите", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.