Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

помогите,плиз..срочно: Написать функцию,которая осуществляет поиск буквы в заданной строке.Функция возвращает истина если в строке есть хотябы одна эта

10-11 класс

буква и ложь в противном случае.

Rznknsts 23 февр. 2015 г., 10:50:05 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alexeyyy28
23 февр. 2015 г., 13:19:02 (9 лет назад)

Program bukva;

var s:string; i,n:integer; c:char;

function Proverka(s:string):boolean;

begin

 for i:=1 to length(s) do   

    if s[i]=c then n:=n+1;

 if n>0 then Proverka:=true else Proverka:=false;

end;

begin

  writeln('Daite stroku'); readln(s);

  writeln('Kakaya bukva doljna biti?'); readln(c);

  writeln(Proverka(s));

readln;

end.

+ 0 -
Sikretik
23 февр. 2015 г., 14:26:36 (9 лет назад)

var

  a: char; //Символ, который надо найти

  s: string; //Строка в которой надо искать

function Search(Symbol: char; Stroka: string): boolean;{Функция логического типа с входными параметрами - символом и строкой} 

var i: integer; //Переменная для цикла

begin

  Result:= false;{Вначале присваиваем функции значение false, чтобы если в строке не будет найден символ, она вернула значение false}

  for i:= 1 to length(Stroka) do //Проверяем все символы строки

    if Stroka[i] = Symbol then Result:= true; {Если символ строки равен символу, который ищут, то присваиваем функции значение true}

end;//Конец функции

begin

  writeln('Введите строку, в которой нужно искать символ');

  readln(s);

  writeln('Введите символ, который нужно искать в строке');

  readln(a);

  writeln('Результат выполнения функции: ', Search(a, s)); {Выводим значение функции}

end.

Ответить

Другие вопросы из категории

Запишите порядок команд в алгоритме получения из числа 11 число 13, содержащие 5 команд, указывая лишь номера команд: а - команда 1: умножь на 3; команда

2: вычти 2! Например, алгоритм получения из числа 2 число 8:12122! Прошу напишите ответ

1.Дана строка: ПЛУВЕТ ЛАДКА. Напишите действия,которые необходимо сделать со строкой,чтобы получилось:ПЛЫВЕТ ЛОДКА

2.Дано слово ДЕРЕВО.Напишите действие,которое необходимо сделать со словом,чтобы получилось:ДЕЛРЕВО

Сколько различных решений имеетСколько различных решений имеет уравнение (К v L)--> (L& М &N) = ложь, где K, L, M, N - логические

переменные ? (Указатель количество различных наборов значений переменных K, L, M, N, удовлетворяющих уравнению.) 1) 4; 2) 10; 3) 8; 4) 12

ПОМОГИТЕ!!!!!

Дана матрица А (4, 5)
2, 3, -5, -10, 7
4, -10, -3, 2, 4
5, -2, -7, 11, -13
18, 19, -2, -4, -7
Из нее образовать две матрицы: в одной оставить все отрицательные элементы матрицы А (на месте положительных элементов поставить ноль), в другой оставить все положительные элементы (на месте отрицательных поставить ноль).
НАПИСАТЬ ПРОГРАММУ в VBA excel

Читайте также

1)Написать программу, которая спрашивает имя пользователя, а потом здоровается. 2)Написать программу, которая выводит на экран перевёрнутый

текст.

3)Написать программу, которая определяет является ли слово палиндромом.

4)Написать программу, определяющую какая из букв а или о встречается в тексте первой.

Помогите хотябы одну пожалуйста))Нужно до завтра!))

помогите решить задачки по Паскалю "4": Составить функцию, которая определяет сумму всех чисел от 1 до N и привести пример ее

использования. Пример: Введите число: 100 сумма = 5050

"5":

Составить функцию, которая определяет, сколько зерен попросил положить на N-ую клетку изобретатель шахмат (на 1-ую – 1 зерно, на 2-ую – 2 зерна, на 3-ю – 4 зерна, …) Пример: Введите номер клетки: 28 На 28-ой клетке 134217728 зерен.

1) Составить функцию, которая определяет наибольшее из трех чисел и привести пример ее использования. Пример: Введите три числа:

28 15 10

Наибольшее число: 28

2)Составить функцию, которая определяет сумму всех чисел от 1 до N и привести пример ее использования.

Пример:

Введите число:

100

Сумма = 500

Буду очень признателен за помощь.

1. Написать программу, которая выводит на экран сумму средних арифметических значений двух вещественных массивов из 10 элементов.

2. Написать прогрумму,которая выводит на экран, разность значений двух вещественных массивов из 10 элементов.



Вы находитесь на странице вопроса "помогите,плиз..срочно: Написать функцию,которая осуществляет поиск буквы в заданной строке.Функция возвращает истина если в строке есть хотябы одна эта", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.