Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

очень надо, помогите прошу Дано целое число К. Вывести строку-описание оценки, соответствующей числу К (1- "плохо" , 2-

10-11 класс

"неудовлетворительно" , 3 - "удовлетворительно" , 4- "хорошо" , 5- "отлично". Если К не лежит в диапазоне 1-5 , вывести "ошибка".

Ksenia987654321 24 авг. 2016 г., 2:04:28 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Abakarova1998
24 авг. 2016 г., 3:16:29 (7 лет назад)

во вложениях скрин Паскаль АВС. должно быть правильно

+ 0 -
Aoshovskaya
24 авг. 2016 г., 4:56:34 (7 лет назад)

Можно ещё использовать оператор выбора case

 

Program pr;
uses crt;
Var k:integer;
Begin
Writeln('Введите k');
readln(k);
if (k>=1) and (k<=5) then
Begin
case k of
1: Writeln('Плохо');
2: Writeln('Неудовлетворительно');
3: Writeln('удовлетворительно');
4: Writeln('Хорошо');
5: Writeln('Отлично');
end;
end
else Writeln('Ошибка');
readln;
end.

Ответить

Читайте также

помогите коле и напишите программу или алгоритм которое находит все просые числа в диапазоне от m до N ВКлючительно

в задаче требуется написать программу которая по двум заданным числам находила бы в диапазоне между этими числами все простые числам где простое число которое имеет всего лишь два делителя то есть оно делится на единицу и на само себя и больше оно не на что не делиться например -3 7 11 помогите )) олимпиада по инфе )) даю максимум баллов ))

Дана строка.

Если она представляет собой запись целого числа, то вывести 1, если
вещественного (с дробной частью) — вывести 2; если строку нельзя
преобразовать в число, то вывести 0. Считать, что дробная
часть вещественного числа отделяется от его целой части десятичной точкой «.».

иЗ ЧИСЛА И МЕСЯЦА сВОЕГО РОЖДЕНИЯ СОСТАВЬТЕ ТРЕХЗНАЧНОЕ ЧИСЛО СЛЕДУЮЩИМ ОБРАЗОМ:ЕСЛИ ДЕНЬ В ДАТЕ РОЖДЕНИЯ-ЧИСЛО ОТ 1 ДО 9,ТО К ЦИФРЕ ИЗ ОБОЗНАЧЕНИЯ ДНЯ

ПРИПИШИТЕ ДВЕ ЦИФРЫ МЕСЯЦА(НАПРИМЕР,ДЛЯ ДАТЫ 02.03.93 ИСКОМОЕ ЧИСЛО 203)ЕСЛИ ДЕНЬ В ДАТЕ РОЖДЕНИЯ-ЧИСЛО ОТ 10 ДО 31,ТО К ДВУМ ЦИФРАМ ИЗ ОБОЗНАЧЕНИЯ ДНЯ ПРИПИШИТЕ ВТОРУЮ ЦИФРУ ИЗ ОБОЗНАЧЕНИЯ МЕСЯЦА(НАПРИМЕР,ДЛЯ ДАТЫ 23.11.93 ИСКОМОЕ ЧИСЛО 231) мОЯ ДАТА РОЖДЕНИЯ 30.05.95



Вы находитесь на странице вопроса "очень надо, помогите прошу Дано целое число К. Вывести строку-описание оценки, соответствующей числу К (1- "плохо" , 2-", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.