Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Задача: нужно составить на паскале такую программу,что бы писать туда четырёх значное число,чтобы это число раскладывалось по цифрам,находилось

5-9 класс

произведение и сумма этих цифр, и находилась большая цифра

13705km 30 янв. 2017 г., 18:54:40 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Fiksik2507
30 янв. 2017 г., 20:34:33 (7 лет назад)

uses crt;
var a,max,sum,pr,a1,a2,a3,a4:integer;
begin
     write('Введите число: '); readln(a);
     a1:=a div 1000;
     a2:=a div 100 mod 10;
     a3:=a mod 100 div 10;
     a4:=a mod 10;
     sum:=a1+a2+a3+a4;
     pr:=a1*a2*a3*a4;
     if a1>=a2 then max:=a1 else max:=a2;
     if max<=a3 then max:=a3;
     if max<=a4 then max:=a4;
     writeln('Сумма цифр числа: ',sum);
     writeln('Произведение цифр числа: ',pr);
     writeln('Максимальная цифра в числе: ',max);
end.

Ответить

Читайте также

составить на Паскале: 1) программу для вычисления суммы ряда S=1+ 1/2+1/3+1/4+..+1/N. Число N вводится с клавиатуры. 2) одноклеточная

амеба каждые 3 часа делиться на 2 клетки. Определить, сколько амеб будет через 3,6,9,12 и 24 часа.

3) дано натуральное числоо N и действительное число Х. Вычислить сумму ряда sin(x)+sin(2x)+sin(3x)+...+sin(Nx).

4) написать программу для вычисления n-ой степени числа А.

помогите, пожалуйста)

Помогите решить задачки на паскале я совсем не разбираюсь в этом!!! 1)Дана таблица со значениями среднемесячных температур в течение года. Составить

программу на Паскале, в которой вычисляются четыре величины: средние температуры зимних месяцев, весенних месяцев, летних и осенних. 2)Вы посетили магазин и купили 10 видов товара. В таблицу T [1..10] записали количество купленного товара каждого вида. В таблицу C [1..10] записали цену единицы каждого вида товара соответственно. Составить программу на Паскале вычисления общей стоимости всех покупок.

На паскале написать программу которая в последовательность чисел( натуральных), определяет сумму всех чисел кратных 4 и оканчивающихся на 6. Программа

получает на вход нат числа, признаком окончания ввода явл число 0.
Могу решить и сам, только нельзя на компе проверить. Так что надеюсь на вас.

Найти алгоритм минимума из 3х целых чисел на паскале+ составить блок -схему.

ПОЖАЛУЙСТА,ХОТЯ БЫ НА ПАСКАЛЕ СОСТАВЬТЕ!



Вы находитесь на странице вопроса "Задача: нужно составить на паскале такую программу,что бы писать туда четырёх значное число,чтобы это число раскладывалось по цифрам,находилось", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.