Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Найдите сумму натуральных нечетных чисел не превышающих n!Сделать нужно циклом репид!

10-11 класс

Nastya20033002 31 авг. 2013 г., 16:51:03 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vic888ca55
31 авг. 2013 г., 18:31:11 (10 лет назад)

var n,a,sum:int64;
begin
  a:=1;
  writeln('Vvedite n');
  readln(n);
  repeat
    sum:=sum+a;
    a:=a+2;
  until(a>=n);
  writeln(sum);
  readln;
end.

Ответить

Другие вопросы из категории

Доступ к файлу come.doc, находящемуся на сервере doc.net, осуществляется по протоколу ftp. Фрагменты

адреса файла закодированы буквами от А до Ж. Запишите последовательность этих букв, кодирующую адрус указанного файла в сети Интернет:
А) ://
Б) come
В) /
Г) .doc
Д) ftp
Е) net
Ж) doc.

Читайте также

1)Найдите сумму натуральных нечетных чисел не превышающих n!!!!Это нужно сделать циклом for. 2) Составьте программу,которая производит

суммирование произвольного количества целых чисел вводимых с клавиатуры.Концом последовательности служит ввод отрицательного числа.Программу составьте двумя способами: использую цикл с предусловием и цикл с постусловием

Напишите программу, которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел, не превосходящих

256. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести два числа: длину последовательности и сумму положительных чётных чисел, не превосходящих 256.



Вы находитесь на странице вопроса "Найдите сумму натуральных нечетных чисел не превышающих n!Сделать нужно циклом репид!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.