Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите пожалуйста составить программу в Паскале: Дан

10-11 класс

целочисленный массив из N элементов.
Вывести на экран сумму всех четных чисел
в этом массиве.

тюльпан3557 03 янв. 2014 г., 9:22:57 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Symerki80
03 янв. 2014 г., 10:08:16 (10 лет назад)

uses crt;
var  m:array[1..10] of integer; 
sum,n,i:integer;
begin 
write('Введите размер массива:: '); 
readln(n); 
writeln('Введите значения массива:'); 
for i:=1 to n do   
read(m[i]);  for i:=1 to n do  begin     
if m[i] mod 2=0 then sum:=sum+m[i]; 
end; 
writeln('Сумма равна: ',sum);
end.

+ 0 -
MeowAnnu
03 янв. 2014 г., 11:23:36 (10 лет назад)

Решение во вложениях. Удачи. 

Ответить

Другие вопросы из категории

Составить алгоритм и написать программу для решение задачи с использованием двумерных массивов и конструкций цикла в цикле:


Вычислить
сумму положительных элементов матрицы А (10х10), расположенных над главной
диагональю. Индекс номера строки i изменяется
от 1 до 9, а индекс номера столбца j изменяется от –i+1
до 10.

Читайте также

Здравствуйте, уважаемые :) Помогите пожалуйста составить программу на Паскале. Спасибо огромное!

1. Напишите программу формирования и вывода массива размером 6x3, каждые три последовательных элемента в строке которого составлены по следующему правилу:
1-й — равен случайному числу;
2-й — равен целой части квадратного корня из предыду щего элемента;
3-й-равен сумме двух предыдущих элементов.

Помогите пожалуйста написать программу в паскале.

Составить программу перевода натурального числа из десятичной системы счисления в двоичную

10-11 класс информатика ответов нет
Дан прямоугольный массив целых положительных чисел 10 х 20. Опишите на русском языке или на одном из языков программирования алгоритм поиска строки с

наименьшей суммой элементов. Вывести на печать номер строки и сумму ее элементов. Предполагается, что такая строка единственна.

помогите пожалуйста составить программу в Паскале!!



Вы находитесь на странице вопроса "Помогите пожалуйста составить программу в Паскале: Дан", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.