Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

1.Напишите команды, которые выполняют следующие действия: а) вывод переменной с ;б) описать переменные а и s целого типа; в) переменной r присваивает

10-11 класс

разность чисел p и q.
2.Что будет на экране после выполнения следующих команд: а) Writeln(9); Write(5); Writeln(3); б) Writeln(4*2); Write('5-3'); Writeln('5+1=',5+1);
3.Укажите различия циклов While и Repeat
4.Дана строка. Определить сколько пробелов в этой строке
6.Дано четырехзначное число. Вывести на экран сумму цифр этого числа
7.Найти количество цифр целого числа N
8.Напишите команды, которые выполняют следующие действия: а) ввод переменной d б) описать переменные m и n вещественного типа. в) переменной s присвоить разность чисел p и q
9.Что будет на экране после выполнения следующих команд: Writeln(5-3); Write('5+3'); Writeln('5*4=',5*4);
10.Когда нельзя применять цикл for
11.Дана строка. Определить сколько букв в этой строке
12.Дано трехзначное число. Вывести на экран все его цифры столбиком
13. Найти количество цифр целого числа N(+блок-схема)

Pek2004 24 марта 2014 г., 14:45:51 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Вконтакте12
24 марта 2014 г., 17:38:44 (10 лет назад)

1
а) writeln(c); или write(c);
б) a, s: integer; или a, s: byte; или a, s: word;
в) r := p - q;

2
а) на одной строке будет выведено число 9, а на другой числа 5 и 3
б) на одной строке будет выведено число 8, на другой выведется 5-3 и 5+1=6

3
While - цикл с предусловием (условие идет до тела цикла), поэтому он может вообще не выполнятся. Repeat - цикл с постусловием (условие идет уже после тела цикла), поэтому тело этого цикла всегда выполняется минимум 1 раз.

4
var
st1: string;
i, k: byte;
begin
write('Введите строку: ');
readln(st1);
for i:=1 to Length(st1) do
if st1[i]= ' ' then inc(k);
writeln(k);
end.

6
var
a, sum: integer;
begin
write('Введите число: ');
readln(a);
sum := 0;
while a > 0 do 
begin 
sum := sum + (a mod 10); 
a := a div 10; 
end; 
writeln('Сумма цифр = ', sum:5);
end.

7
var
N, k: integer;
begin
write('Введите число: ');
readln(N);
k:=0;
while N > 0 do 
begin 
inc(k); 
N := N div 10; 
end; 
writeln('Количество цифр = ', k:5);
end.

8
а) read(d); или readln(d);
б) m, n: real; или m, n: double;
в) s := p - q;

9
На одной строке будет выведено 2, на другой 5+3 и 5*4=20

10
Ну, думаю, когда заранее неизвестно число итераций (повторений) цикла. Например While eof(f) ("пока не конец файла", тут чисто физически нельзя использовать цикл for).
11 
Length(st1), если с выводом, то Writeln('Количество символов: ', Length(st1));

12
var
N: integer;
begin
write('Введите число: ');
readln(N);
writeln(N div 100);
writeln(N div 10 mod 10);
writeln(N mod 10);
end.

13
Код идентичен заданию 7, блок-схема в приложении

Ответить

Другие вопросы из категории

Решите задачи.а) Маша, Даша, Катя и Оля учатся в одной школе, но в разныхклассах:7 «А», 7 «Б», 8 «А». Катя и Оля – одноклассницы. Маша и Катяучились в

классах с одинаковой литерой. Маша и Даша былиученицами седьмого класса. Кто в каком классе учился?

Какую клавишу надо использовать при удалении объекта, чтобы он не попал в Корзину?

Вариант 1 Ctrl
Вариант 2 Shift
Вариант 3 Home
Вариант 4 Alt

Составить программу, которая вычисляет сумму элементов главной диагонали в

двумерном массиве размерности 3х3. Заполнить массив целыми случайными числами из
диапазона от 0 до 15.

реферат набранный на компьютере содержит 48 страниц,на каждой странице 36 строк,в каждой строке 48 символов.для кодировки символов используется

кодировка кои-8,при которой каждый символ кодируется 8 битами.определите информационный объем

Читайте также

Исполнитель КАЛЬКУЛЯТОР имеет только две команды, которым присвоены номера:

Умножь на 2

Прибавь 1

Выполняя команду номер 1, КАЛЬКУЛЯТОР умножает число на экране на 2, а выполняя
команду номер 2, прибавляет к числу на экране 1. Напишите программу, содержащую не
более 5 команд, которая из числа 6 получает число 33. Укажите лишь номера команд.

Например, программа 12122 -это программа:
Умножь на 2

Прибавь 1

Умножь на 2
Прибавь 1
Прибавь 1

которая преобразует число 5 в число 24.

Исполнитель КВАДРАТОР имеет только две команды, которым присвоены номера:

1.Возведи в квадрат
2.Прибавь 1
Выполняя команду номер 1, КВАДРАТОР возводит число на экране в квадрат, а выполняя
команду номер 2, прибавляет к этому числу 1. Напишите программу, содержащую не
более 4 команд, которая из числа 2 получает число 36. Укажите лишь номера команд.
Например, программа 2122 – это программа:
Прибавь 1
Возведи в квадрат
Прибавь 1
Прибавь 1
которая преобразует число 1 в число 6.
1221

Иван и Мария взяли числа 5, 10, 28, 32 и с каждым из них выполняли следующие действия, которые называли шагом: если число четное – делили на 2,если число

нечетное – умножали его на 3 и к результату прибавляли 1.с какими из этих чисел результат 1 получится за 6 шагов?
а) 5
б) 10
в) 32
г) 28

Задание 11. Выполните арифметические действия.

1) 110 + 101;
2) 10101-11;
3) 101 ´ 11;
4) 1110:10.

Задание 12. Выполните арифметические действия:

а) 11102 + 10012;
б) 678 + 238;
в) AF16 + 9716;
г) 11102 - 10012;
д) 678 - 238;
e) AF16 - 9716;
ж) 11102 × 10012;
з) 678 × 238;
и) AF16 × 9716;
к) 10102 : 102;
л) 748 : 248;
м) 5А16 : 1Е16.

Напишите программу, которая вычисляет НОД двух чисел. Используйте функцию.

Напишите программу, которая вычисляет НОК двух чисел. Используйте функцию.



Вы находитесь на странице вопроса "1.Напишите команды, которые выполняют следующие действия: а) вывод переменной с ;б) описать переменные а и s целого типа; в) переменной r присваивает", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.