Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

помогите пожалуйста составить программу паскаль и объясните ее

10-11 класс

дано четырехзначное число,получить новое поменяв местами первую и последнюю цифру

головр 13 дек. 2016 г., 18:09:16 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kalelova98
13 дек. 2016 г., 19:30:42 (7 лет назад)

program zamena;
var s:string;
     x,y:char;
begin
write('Введите четырехзначное число: ');
readln(s);
x:=s[1]; y:=s[4];
s[1]:=y; s[4]:=x;
writeln('Полученное число: ',s);
end.

Считываем число как строку. Символьной переменной "X" присваиваем значение первого символа строки (первой цифры числа). Символьной переменной "Y" присваиваем значение четвертого символа строки (четвертой цифры числа). Делаем обмен первой и четвертой цифры числа: присваиваем первому символу значение переменной "Y", а четвертому символу - значение переменной "X". Выводим получившуюся строку (число) на экран.

Ответить

Другие вопросы из категории

Какая информация будет больше всего занимать места на диске?

Ответы одно из четырёх:
Текс
Фотография
Музыка
Видео

3. Записать логические формулы, истинные при выполнении следующих условий:

а) хотя бы одно из чисел X, Y, Z положительно;
б) каждое из чисел X, Y, Z равно 0;
в) только одно из чисел X, Y, Z не больше 100.

1.Переведите

известным вам способом число 12 в
двоичную систему счисления.

Читайте также

Здравствуйте, уважаемые :) Помогите пожалуйста составить программу на Паскале. Спасибо огромное!

1. Напишите программу формирования и вывода массива размером 6x3, каждые три последовательных элемента в строке которого составлены по следующему правилу:
1-й — равен случайному числу;
2-й — равен целой части квадратного корня из предыду щего элемента;
3-й-равен сумме двух предыдущих элементов.

Помогите пожалуйста написать программу в паскале.

Составить программу перевода натурального числа из десятичной системы счисления в двоичную

10-11 класс информатика ответов нет
Дан прямоугольный массив целых положительных чисел 10 х 20. Опишите на русском языке или на одном из языков программирования алгоритм поиска строки с

наименьшей суммой элементов. Вывести на печать номер строки и сумму ее элементов. Предполагается, что такая строка единственна.

помогите пожалуйста составить программу в Паскале!!

Помогите пожалуйста с программой..(в Паскале)

Составить программу табулирования функции заданной рекурентной формулой.
f(0)=1; f(1)=2; f(n+2)=2*f(n+1)-n



Вы находитесь на странице вопроса "помогите пожалуйста составить программу паскаль и объясните ее", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.