Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Выбрать в каждой строке матрицы B(6,5) минимальный элемент и вывести его на экран рядом с матрицей. ЯЗЫК ПРОГРАММИРОВАНИЯ ПАСКАЛЬ!

10-11 класс

Уыльям 07 апр. 2017 г., 4:30:29 (6 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
NiceCold
07 апр. 2017 г., 7:18:23 (6 лет назад)

Массив вводится вручную, минимальный элемент указан в той же строке, где найден.
Program asd;
var B:array [1..6,1..5] of integer; i,j,min:integer;
begin
for i:=1 to 6 do 
for j:=1 to 5 do 
read(B[i,j]); 
for i:=1 to 6 do 
begin min:= B[i,1]; 
  for j:=1 to 5 do 
 begin if B[i,j]<min then min:=B[i,j];     
   write (B[i,j],'  ');
 end; 
 writeln ('минимальный элемент равен  ',min); end;
 end.

Ответить

Другие вопросы из категории

Написать программу, определяющую состоит ли трехзначное число из одинаковых цифр.

Подсказка: в материалах урока есть программа по определению цифр в двузначном числе!

Выбери верное утверждение.

1) Для облачного сервера можно динамически изменять используемые ресурсы памяти процессора.
2) Облачный сервер всегда должен находиться в другой организации.
3) Физический сервер может обслуживать только запросы, приходящие о т зарегистрированных пользователей.
4) На физический сервер можно установить и Linux и Windows, а на облачный только Windows.

Читайте также

Заполнить матрицу из 8 строк и 5 столбцов случайными числами в интервале [10;10] и вывести ее на экран.

Удвоить все элементы матрицы и вывести ее на экран.
Найти минимальные и максимальные элементы в матрице, указать номера.
Просто матрица и удвоенная есть. Теперь нужно найти мин. и макс. значения

program ff;
uses crt;
const n=8;
m= 5;
var a:array [1..n, 1..m] of integer;
i,j:integer;
begin
writeln ('Матрица:');
for i:=1 to 8 do begin
for j:=1 to 5 do begin a[i,j]:=-10+random(21);
write(a[i,j]:4);
end;
writeln;
end;

for i:=1 to 8 do
for j:=1 to 5 do
a[i,j]:=a[i,j]*2;
writeln ('Удвоенная матрица:');
for i:=1 to 8 do begin
for j:=1 to 5 dowrite(a[i,j]:4);
writeln;
end;
end.

Заполнить матрицу из 8 строк и 5 столбцов случайными числами в интервале [-10;10] и вывести на ее на экран.

Удвоить все элементы матрицы и вывести ее на экран.



Вы находитесь на странице вопроса "Выбрать в каждой строке матрицы B(6,5) минимальный элемент и вывести его на экран рядом с матрицей. ЯЗЫК ПРОГРАММИРОВАНИЯ ПАСКАЛЬ!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.