Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Даны два числа. Найти среднее арифметическое кубов этих чисел и среднее геометрическое модулей этих чисел.

10-11 класс

Помагите плииз)!!

мурау 24 июня 2013 г., 9:56:15 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nastya21012003
24 июня 2013 г., 11:38:21 (10 лет назад)

var
  a, b: real;

begin
  Write('Введите два числа через пробел ');
  Readln(a, b);
  Writeln('Среднее арифметическое кубов равно ', (a * sqr(a) + b * sqr(b)) / 2);
  Writeln('Среднее геометрическое модулей равно ', sqrt(abs(a * b)))
end.

Тестовое решение:
Введите два числа через пробел -13.5 17.43
Среднее арифметическое кубов равно 1417.4722035
Среднее геометрическое модулей равно 15.3396544941534

**********************
Замечание: вместо произведения модулей при вычислении среднего геометрического достаточно взять модуль произведения - в любом случае получится требуемое положительное число.

Ответить

Другие вопросы из категории

Читайте также

Даны два числа. Найти

среднее арифметическое кубов этих чисел.

1)Найдите ошибки в программах:

a) Program Ошибки1;
Begin
Summa:=6+8;
End;
b) Program Ошибки2;
Begin
Var X:integer;
X:=6+8;
Write(X);
End;




2)Даны два числа. Найти среднее арифметическое кубов этих чисел и среднее геометрическое модулей этих чисел.
ДАННУЮ ПРОГРАММУ НУЖНО НАПИСАТЬ В ПАСКАЛЕ.

Задан одномерный массив размером 40. Определите количество элементов массива и среднее арифметическое значение этих элементов, которых больше заданного

числа 7 и меньше 10. Вывести количество элементов массива и среднее арифметическое значение этих элементов, которых больше заданного числа 7 и меньше 10 на монитор

ПАСКАЛЬ.1)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 1000.опишите на русском языке или на одном из

языков программирования алгоритм,позволяющий найти среднее арифметическое нечетных трехзначных чисел,записанных в этом массиве.если ни одного такого числа нет,нужно вывести сообщение об этом.
2)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 100.опишите на русском языке или на одном из языков программирования алгоритм,позволяющий найти и вывести произведение элементов массива,которые имеют четное значение и не оканчиваются на 0.



Вы находитесь на странице вопроса "Даны два числа. Найти среднее арифметическое кубов этих чисел и среднее геометрическое модулей этих чисел.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.