Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Вычислить сумму ряда с точностью e=10–6 Ряд прикреплен в файле

10-11 класс

Задача на Pascal

Аришка1024 01 янв. 2017 г., 23:14:43 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Xxx3333
02 янв. 2017 г., 0:44:39 (7 лет назад)

program ddm;

 uses crt;

 var a,x,i:integer;

m,j,h,f,l:real;

 begin

 clrscr;

 writeln('Введите х');

 readln(x);

 writeln('Введите a');

 readln(a);

 j:=x;

 for i:=1 to a+1 do

 begin

j:=j*x;

 h:=(i+1)*j + 1;

 f:=sqr(i+1);

 l:=h/f;

 if (i+1)mod 2 = 0 then

m:=m+l

else m:= m-l;

end;

writeln(m:2:5);

readkey;

end.

Ответить

Другие вопросы из категории

Ре­фе­рат, на­бран­ный на ком­пью­те­ре, со­дер­жит 12 стра­ниц, на каж­дой стра­ни­це 48 строк, в каж­дой стро­ке 64 сим­во­ла. Для ко­ди­ро­ва­ния

сим­во­лов ис­поль­зу­ет­ся ко­ди­ров­ка Unicode, при ко­то­рой каж­дый сим­вол ко­ди­ру­ет­ся 16 би­та­ми. Опре­де­ли­те ин­фор­ма­ци­он­ный объём ре­фе­ра­та.

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 6; 4; 2; 5; 1; 7; 1; 8; 4; 8 соответственно,

т.е. A[0] = 6; A[1] = 4 и т.д.

c := 0;
for i := 4 to 9 do
if A[i - 1] < A[i] then
begin
c := c + 1;
t := A[i];
A[i] := A[i - 1];
A[i - 1] := t
end;
Определите значение переменной c после выполнения следующего фрагмента программы, записанного ниже на разных языках программирования.

Помогите, пожалуйста!!!

С понятием переменной не связано:


1. Имя

2. Значение

3. Тип

4. Свойство

Читайте также

Помогите пожалуйста. Не могу понять как решить.

Вычислить сумму корней квадратных первых N чисел натурального ряда.

Входные данные:Во входном потоке записано единственное целое число N (0 < N <= 100).

Помогите пожалуйста. Что мне нужно добавить в код?

Вычислить сумму корней квадратных первых N чисел натурального ряда.

Входные данные:Во входном потоке записано единственное целое число N (0 < N <= 100).

Для заданного положительного e и заданного x вычислить сумму ряда с точностью e. Суммирование ряда завершается, если модуль очередного слагаемого меньше

e. Определив тип общего члена ряда, и организовав вычисление его суммы со структурой вложенных циклов, получить таблицу, состоящую из переменных X, Y, S, при |X|<1.

Задание 2 Тема: Ряды (циклы, итерации). Операторы DO используются для организации цикл

ических расчетов.

Цикл - это последовательность операторов, которая может автоматически выполняться более одного раза. Если количество повторов известно заранее (или может быть однозначно вычислено), используется оператор Цикл_с_параметром (DO «UNTIL»). Если количество повторов неизвестно, применяется оператор Цикл_с_Пред_условием (DO «WHILE»).

Вычислить сумму ряда:

a) с заданной точностью ξ и вывести количество итераций;

b) для 20-ти членов ряда.

Σ = 1/(1*3) + 1/(3*5) + 1/(5*7) + … ξ=0.0001 Ответ: 0.500

Вычислите сумму

цифр в числе. (Например, в числе 352 сумма цифр = 10)



Вы находитесь на странице вопроса "Вычислить сумму ряда с точностью e=10–6 Ряд прикреплен в файле", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.