Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

СРОЧНО!!Напишите функцию в Паскале,которая вычисляет наименьшее общее кратное двух чисел

5-9 класс

Anon04 10 июня 2014 г., 23:31:00 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Bushtinzayka
11 июня 2014 г., 0:58:03 (9 лет назад)

Напишу лучше полностью, а то есть уникумы, которые любят отмечать "неполное решение".
var m,n,a,b:integer; nok:real;
begin
  readln(m,n);
  a:=m;
  b:=n;
while m<>n do
  if m>n then m:=m-n
    else n:=n-m;
  nok:=a*b/m;
  writeln(nok);
end.

Ответить

Другие вопросы из категории

Учителя всегда переживают за своих учеников, особенно на олимпиадах. Вот и сегодня, пока вы решаете эти задачи нам стало известно, что несколько учителей

из одной школы высказались про своих учеников:1. первое место займет Вася, а Юра — второе;2. Саша займет второе место, а Вася — пятое;3. второе место займет Иван, а Гриша окажется четвертым;4. на первом месте будет Гриша, а Юра — на четвертом;5. Юра будет четвертым, а Иван — вторым.На самом деле жюри уже известно, что в каждом высказывании одно утверждение истинно, а второе — нет. Определите кто какое занял место и в ответе напишите пять имен через пробел Юра, Вася, Саша, Иван, Гриша, в порядке занятых ими мест, то есть если Юра - первый, Гриша - третий, Миша - второй, тогда в ответ укажите Юра Миша Гриша

Читайте также

Срочно! 1Дано натур. число. Проверить, является ли число двузначным у которого 1 и 2 цифры одинаковые. 2.Даны 3 числа. Удвоить те из

них,которые нечетны.Остальные отсавить без изменения.

3.ВВедите коль-во учащихся в группе по инфе и четвертную отметку каждого учащегося. Выч. средний бал успеваемости по инфе в группе за четверь.

4.НАйти сумму целых положительных чисел, больших 20, меньших 100 и кратных 3.

5.Вычислить наименьшее общее кратное 2 чисел (hok (a,b)). Для вычесления воспользуйтесь ФОРМУЛОЙ a*b=HOД*HOK



Вы находитесь на странице вопроса "СРОЧНО!!Напишите функцию в Паскале,которая вычисляет наименьшее общее кратное двух чисел", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.