Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Формат входных данных:

5-9 класс

Дано целое число A и натуральное число i.

Формат выходных данных:
Обнулите у числа A его последние i бит и выведите результат обнуления.
Помогите скорей, кто понимает, о чём идет речь!

Murashka4995 03 февр. 2015 г., 12:56:01 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Darkstill2000
03 февр. 2015 г., 15:25:23 (9 лет назад)

Сдвигаем число А вправо на i бит, а потом сдвигаем результат влево на i бит. Освободившиеся правые разряды автоматически заполняются нулями.

var
  a, i, j: integer;

begin
  Write('Введите через пробел целое А и натуральное i: ');
  Readln(a, i);
  a := (a shr i) shl i;
  Writeln('a=', a)
end.

Тестовое решение:

Введите через пробел целое А и натуральное i: 124 5
a=96

Ответить

Другие вопросы из категории

Помогите!

Файл размкром 2000 Кбайт передаётся через некоторое соединение в течение 30 секунд.определите размер файла в Кбайтах, который можно передать через это соединение за 12 секунд.

Читайте также

1.Напишите программу расчёта площади прямоугольника,если известны его периметр и длина одной из сторон. Входные данные вводятся пользователем с экрана.

Вывод так же осуществляеться на экран.
2.Дана последовательность чисел а,b,c. Все отрицательные числа заменить на нули. Входные данные вводятся пользователем с экрана. Вывод так же осуществляется на экран.
Нужно составить вроде таблицу алгоритмов,помогите пожалуйста.
Я не прошу схемотично,хотя бы описание,где что должно быть написано,очень надо,помогите

Определить стоимость покупки с учетом скидки . Скидка в 10% предоставляется если сумма покупки больше 1000 рублей. Входные данные S-стоимость покупки.

ВХОДНЫЕ ДАННЫЕ S- стоимость покупки с учетом скидки( если она предоставляется)

Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N. Формат входных данных Задано единственное число N. Формат выходных

данных Необходимо вывести все точные квадраты натуральных чисел, не превосходящие данного числа N.



Вы находитесь на странице вопроса "Формат входных данных:", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.