Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Тема массив. Напишите на Паскале программу, которая запрашивает с клавиатуры массив из N чисел, а затем выводит среднее арифметическое всех элементов

5-9 класс

массива.

абвр 07 марта 2015 г., 9:09:48 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Diel
07 марта 2015 г., 9:55:46 (9 лет назад)

var
i,a,N:integer;
sr:real;
begin
 write('Vvedite N = '); 
readln(N); // Вводите количество чисел в массиве и одновременно вводите диапозон массива от 1 до N 
randomize;
for i:=1 to N do
begin
a:=random(N);
write(a,' ');
sr:=sr+a; //Значения массива складываются
end;
sr := (sr / N); //Сумма значений массива делится на количество значений
writeln('srednee arifmeti4eskoe = ',sr:1:2); //Выводится среднее арифметическое
readln;
end.

Ответить

Другие вопросы из категории

На сервере

time.vr находится файл doc.txt, доступ к которому осуществляется по протоколу
ftp. Фрагменты адреса данного файла закодированы буквами A, B, C, …, G (см.
таблицу). Запишите последовательность этих букв, которая кодирует адрес
указанного файла в Интернете.

А

Читайте также

Написать на Паскале программу, которая запрашивает с клавиатуры N произвольных целых чисел и ищет их сумму. Число N вводится с клавиатуры. Разработать для

созданной программы не менее трех тестов и проверить на них правильность работы алгоритма.
БЕЗ МАССИВА
ПОЖАЛУЙСТА
+194884839383948 К КАРМЕ ТОМУ КТОНАПИШЕТ

1) Дан

целочисленный массив из 30 элементов. Элементы массива могут принимать значения
от

0 до 1000. Опишите на русском языке или на одном из языков программирования
алгоритм, который находит и выводит среднее арифметическое всех элементов
массива, имеющих нечётное значение. Гарантируется, что хотя бы один такое
элемент в массиве есть.

1)напишите программу которая спрашивала бы название продукта и его цену. И затем на экран выводила фразу "Ваши расходы на покупки равны руб." 2) написать

программу, которая запрашивала три числа, подсчитывала их средне и сумму и на экран выводила фразу "Их среднее равно..." и "Их сумма равна..."



Вы находитесь на странице вопроса "Тема массив. Напишите на Паскале программу, которая запрашивает с клавиатуры массив из N чисел, а затем выводит среднее арифметическое всех элементов", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.