Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

QBASIC

5-9 класс

Задана матриця K(N,L) Знайти кількість відємних, кратних трьом елементів.
Заданная матрица K (N, L) Найти количество отрицательных, кратных трем элементов.

Rozaliya835 18 дек. 2014 г., 1:49:55 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
юдочудо
18 дек. 2014 г., 3:17:13 (9 лет назад)

const
  N = 5;
  L = 8;

var
  K: array[1..N, 1..L] of integer;
  i, j, p: integer;

begin
  Randomize;
  for i := 1 to N do
  begin
    for j := 1 to L do
    begin
      K[i, j] := random(100) - 50;
      write(K[i, j]:5);
    end;
    writeln
  end;
  p:=0;
  for i := 1 to N do
    for j := 1 to L do
      if (K[i, j]<0) and (K[i,j] mod 3=0) then p:=p+1;
  writeln('Найдено отрицательных элементов, кратных трем: ',p)
end.

Тестовое решение:

   27   42    0   25  -49   41  -16  -14
  -26  -29   27  -16   10  -16   17   18
   -4   10   17  -26   45  -23   48  -44
  -47   28   25   -1  -31   24   35  -47
  -39   49  -48   29  -42    2   -6   32
Найдено отрицательных элементов, кратных трем: 4



+ 0 -
Мэри16Мэри
18 дек. 2014 г., 6:05:26 (9 лет назад)

Комментарий удален

+ 0 -
Shipovnick01
18 дек. 2014 г., 8:10:26 (9 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

Составьте программу которая выводит на экран значение выражения а=в7

В в седьмой степани.
Program...
var...
begin
......
end.
Плиз хелпт!!!

I В паскале с помощью генератора случайных чисел получить двузначное число и

1) найти и вывести сумму его цифр
2) сформировать число, в котором поменяются разряды (допустим будет число 13, нужно сделать, что бы было 31 и т.п.)
II В паскале с помощью генератора случайных чисел получить трехзначное число и определить, является ли оно полимером (например 121 - является, 123 - нет)

функції браузера internet explorer:

зміна кодування тексту сторінки
заміна тексту на сторінці
зміна розміру шрифту тексту сторінки
пошук тексту на сторінці
налагодження якості друку та друкування документів



Вы находитесь на странице вопроса "QBASIC", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.