Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Для пяти произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если первое, второе и пятое числа отрицательны, то

10-11 класс

выведите их произведение. Если третье и четвёртое числа больше100, то выведите среднее арифметическое всех пяти чисел. Если выполняются одновременно два перечисленных выше условия, то выведите на экран все пять чисел без изменения. Иначе, выведите третье и пятое числа, увеличив их в два раза.

Veralavrova031 20 окт. 2013 г., 17:05:09 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Prostoab
20 окт. 2013 г., 18:00:56 (10 лет назад)

var a1,a2,a3,a4,a5:real;
u1,u2:boolean;
begin
writeln('Введите 5 вещественных чисел');
readln(a1,a2,a3,a4,a5);
u1:=(a1<0) and (a2<0) and (a5<0);
u2:=(a3>100) and (a4>100);
if u1 and u2 then writeln(a1,' ',a2,' ',a3,' ',a4,' ',a5)
else
if u1 then writeln('a1*a2*a5=',a1*a2*a5)
else
if u2 then writeln('sr.arifm=',(a1+a2+a3+a4+a5)/5)
else writeln(2*a3,' ',2*a5);
end.

Ответить

Другие вопросы из категории

Составьте программу для определения подходящего возраста кандидатуры для вступления в брак, используя следующее соображение: возраст девушки равен

половине возраста мужчины+7, возраст мужчины определяется соответственно как удвоенный возраст девушки-14. В начале выполнения программы на экране должен появиться вопрос МУЖЧИНА или ЖЕНЩИНА? ВВЕДИТЕ М, если Вы мужчина, или Ж, если женщина и свой возраст. В зависимости от ответа выводятся соответствующие рекомендации.

Program mas;

uses crt;
var B: array [1..9] of integer;
i: integer;
Begin
clrscr;
randomize;
for i:=1 to 9 do if ((i mod 2)=0) then B(i):=0 else B(i):=random(100)-100;
End.
постройте пожалуйста блок-схему. Очень срочно!

Читайте также

Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты.

Если первое число четно, то выведите сумму этих четырех чисел.
Если второе и третье числа положительны,то выведите их среднее арифметическое.
Если выполняются одновременно два перечисленных выше условия, то выведите все четыре числа без изменения.
Иначе, выведите числа, противоположные исходным.
Составьте соответствующие отладочные примеры и проверьте работу каждой программы.

Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если все числа не превышают 30, то выведите их

удвоенное произведение. Если последнее число четно, то выведите произведение первых двух чисел, уменьшенное в 10 раз. Если выполняются одновременно 2 условия, то выведите эти числа без изменения. Иначе, выведите разность первого и последнего чисел.
Решить нужно в С или С++
Заранее спасибо!!!

Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если все числа не превышают 30, то выведите их

удвоенное произведение. Если последнее число четно, то выведите произведение первых двух чисел, уменьшенное в 10 раз.
Решить нужно на среде С или С++
Заранее спасибо.

паскаль написать программу Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если сумма

первых двух чисел четна, то выведите эту сумму. Если сумма третьего и четвертого чисел четна и отрицательна, то выведите все четыре числа без изменения. Если выполняются одновременно два перечисленных выше условия, то выведите среднее арифметическое этих четырех чисел. Иначе, выведите суммы двух первых и двух последних чисел.

Напишите программу в паскаль для решения следующей задачи: для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие

результаты. Если первое из них отрицательно, а второе вдвое больше третьего, то выведите среднее арифметическое всех четырех чисел. Если произведение этих четырех чисел больше их суммы, то выведите эти сумму и произведение. Если выполняются одновременно два перечисленных выше условия, то выведите среднее арифметическое этих чисел, их произведение и сумму. Иначе, выведите удвоенные значения этих чисел.



Вы находитесь на странице вопроса "Для пяти произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если первое, второе и пятое числа отрицательны, то", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.