Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Написать в Паскале программу, которая реализует алгоритм работы кассира, дающего сдачу наименьшим количеством банкнот по 500, 100, 50, 10 рублй

5-9 класс

GaukharKudaibergen 14 июля 2014 г., 5:04:26 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vreiko
14 июля 2014 г., 5:49:44 (9 лет назад)

var _500,_100,_50,_10,money_get:integer;beginwriteln('Введите стоимость товара');readln(money_get);while(money_get mod 10 <> 0) do        begin        writeln('стоимость должна делиться на 10, попробуйте еще раз');        readln(money_get);        end;while (money_get>=500) do        begin        _500:=_500+1;        money_get:=money_get-500;        end;while (money_get>=100) do        begin        _100:=_100+1;        money_get:=money_get-100;        end;while (money_get>=50) do        begin        _50:=_50+1;        money_get:=money_get-50;        end;while (money_get>=10) do        begin        _10:=_10+1;        money_get:=money_get-10;        end;
writeln(_500,': 500 рублей',_100,':100 рублей',_50,':50 рублей',_10,':10 рублей');


readln;end.

+ 0 -
Svetik1985
14 июля 2014 г., 8:10:45 (9 лет назад)

то есть полученные деньги и стоимость покупки указывает пользователь?

+ 0 -
Vovycho007
14 июля 2014 г., 10:52:22 (9 лет назад)

да

+ 0 -
Маргулька
14 июля 2014 г., 12:44:40 (9 лет назад)

ок)

+ 0 -
эльыирка
14 июля 2014 г., 14:06:24 (9 лет назад)

На днях писал похожую,только там было 500 100 50 10 5 2 и 1 руб

Ответить

Другие вопросы из категории

дана зашифровваная пословица чтобы рубить дрова нужен 14.2.3.2.7 а чтобы полить огород -10.4.5.1.6.рыбаки сделали во льду 3.7.2.7.8.9.11 и стали ловить

рыбу.самый колючий зверь в лесу это 12,13.а теперь разшифруй пословицу.1.2.3.4.5.1.6,7.8.9.10.11,9.4.7.4.13.12.14 ПОМОГИТЕ ПОЖАЛУЙСТААААА

Читайте также

Написать на Паскале программу, которая запрашивает с клавиатуры N произвольных целых чисел и ищет их сумму. Число N вводится с клавиатуры. Разработать для

созданной программы не менее трех тестов и проверить на них правильность работы алгоритма.
БЕЗ МАССИВА
ПОЖАЛУЙСТА
+194884839383948 К КАРМЕ ТОМУ КТОНАПИШЕТ

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.

5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.

6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.

б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.
б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.
5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева
б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.
6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.
б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.
напишите хоть какое нибудь нужно к завтрому срочно

A) Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 и находит сумму элементов с четными значениями

и количество элементов с нечетными значениями.

б) Составьте программу, которая заполняет массив b[1..8] случайными целыми числами в диапазоне от 1 до 10 и находит произведение элементов с нечетными значениями и количество элементов с четными значениями.

Напишите программу, которая в последовательности целых чисел находит сумму и количество чисел, кратных 17, или сообщает, что таких чисел нет. На вход

программы подаются целые числа, количество введенных чисел неизвестно, последовательность заканчивается числом 0 (0 - признак окончания ввода, не является членом последовательности). Количество чисел не превышает 100. Введенные числа по модулю не превышают 300. Программа должна вывести сумму и количество чисел, кратных 17, или вывести NO, если таких числе в последовательности нет



Вы находитесь на странице вопроса "Написать в Паскале программу, которая реализует алгоритм работы кассира, дающего сдачу наименьшим количеством банкнот по 500, 100, 50, 10 рублй", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.