Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

С клавиатуры вводятся 3 числа. сколько среди них положительных ? Нужно решать либо с if или с case

5-9 класс

Tarikova96 31 дек. 2016 г., 17:16:41 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Avetyanjemma1
31 дек. 2016 г., 19:20:14 (7 лет назад)

program q;
var mult, a, b, c:integer;
begin
  write('введите 3 числа');
  read(a,b,c);
mult:=0;
if a>0 then 
 mult:=mult+1
else mult:=mult;
end;
if b>0 then
 mult:=mult+1
else mult:=mult;
if c>0 then 
  mult"=mult+1
else mult:=mult;
end;
writeln('положительных ' ,mult, '  чисел');
end.  

Ответить

Другие вопросы из категории

Какие из следующих словосочетаний являются понятиями? 1) система счисления 2) текстовый файл 3)текстовый документ может иметь

расширение txt

4) файл – это информация, хранящаяся во внешней памяти как единое целое и обозначенная именем

5) всего существует 256 различных цепочек из 8 нулей и единиц

6) двоичный код

Дан файл f, элементы которого являются целыми числами. Никакой из элементов файла не равен нулю. Файл f содержит столько же отрицательных чисел, сколько и

положительных. Используя вспомогательный файл h, переписать элементы файла f в файл g так, чтобы в файле g:
- не было двух соседних чисел с одним знаком,
- сначала шли положительные, потом отрицательные числа.

Читайте также

1.С клавиатуры вводится действительное число a.Найти его квадратный корень.

2.С клавиатуры вводится действительное число p.Записать отдельно его целую часть C.
Помогите составить программу.

В ПАСКАЛЕ!№1 С клавиатуры вводятся 10 натуральных двузначных чисел. Определить сколько среди них чисел, кратных 4; №2 С клавиатуры вводятся 10

натуральных двузначных чисел. Определить

среднее арифметическое нечетных чисел;

№3 С клавиатуры вводятся 10 натуральных двузначных чисел. Определить

верно ли, что среди введенных чисел есть число, в котором первая цифра в два раза больше последней.



Вы находитесь на странице вопроса "С клавиатуры вводятся 3 числа. сколько среди них положительных ? Нужно решать либо с if или с case", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.