Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

PASCAL-ABC.NET Здравствуйте,прошу помочь с не очень сложной задачкой.

5-9 класс

Условия:
Заполнить двумерный массив A случайными числами и построить одномерный массив B,в каждый елемент которого записано:
число елементов каждого стольбца двухмерного массива,значения которых равны заданному значению.
Вопросы вот где " и построить одномерный массив B,в каждый елемент которого записано:
число елементов каждого стольбца двухмерного массива,значения которых равны заданному значению." как это построить? У меня в голове нету абсолютно никаких мыслей.Очень прошу помочь.

Alenabrovko 18 авг. 2013 г., 8:06:48 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
2002sona2013
18 авг. 2013 г., 10:55:27 (10 лет назад)

Заводите счетчик, допустим, к, который считает к-во элементов столбцов, удовлетворяющих условию. Изначально к=0.
for j:=1 to n do
 begin
for i:=1 to m do
  if a[i,j] = c (где с - заданное значение)
    then k++;
  b[j]:=k;
k:=0;
 end;

обратите внимание на индексацию! двумерный массив мы должны пройти не горизонтально (по строкам), как обычно, а по столбцам.

+ 0 -
Guerrero17
18 авг. 2013 г., 11:32:44 (10 лет назад)

Program Version10medium;
const
MaxN = 5; MaxM = 5;
type
MyArray = array[1..MaxN, 1..MaxM] of Integer;

+ 0 -
Nicetrineev
18 авг. 2013 г., 12:59:33 (10 лет назад)

var
A: MyArray;
B:Array[1..1000] of Integer;
i:Integer;8
procedure TInitMas(n, m: Integer; var A: MyArray;B:Array of integer);
const ot = 1; ido = 10;
var
i, j: Integer;
k,l:Integer;
begin

+ 0 -
Тяна
18 авг. 2013 г., 14:12:40 (10 лет назад)

Randomize;
Writeln('Заполнение двумерного массива случайными числами');
for i := 1 to n do
begin
for j := 1 to m do
begin
A[i, j] := Random(ot, ido);
Write(A[i, j] : 4);
end;
Writeln();
end;
end;

+ 0 -
Logika2014
18 авг. 2013 г., 15:01:24 (10 лет назад)

procedure TWriteMas(n, m: Integer; A: MyArray);
var
i, j : Integer;
begin
Writeln('Результат работы программы');
for i := 1 to n do
begin
for j := 1 to m do
begin
Write(A[i, j] : 4);
end;
Writeln();
end;
end;

+ 0 -
Wwwkamilaboka
18 авг. 2013 г., 16:10:57 (10 лет назад)

begin
Write('Значение каждого столбца двухмерного массива');
readln(b);
For i:= 1 to n do
begin
b[i]:= MaxN;
end;
TInitMas(MaxN, MaxM, A);
TWriteMas(MaxN, MaxM, A);
end.

Ответить

Другие вопросы из категории

Задача на паскале Задан массив А размерности N случайным образом.

Нужно сформировать новый массив по следующему правилу:
все чётные элементы разделить на 2, все нечётные оставить без изменения

Читайте также

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC.

Составить программу,которая выводит на экран сумму нечетных чисел от 1 до 30 в Pascal ABC.


1) дано четырёхзначное число. вывести максимальную и минимальную цифру. pascal abc

2) дано четырёхзначное число. Что больше: произведение цифр числа или их утроенная сумма. pascal ABC

решите пожалуйста задачи на языке pascal abc net.

f3.
Дано целое число. Если оно является положительным, то прибавить к нему 1; если отрицательным, то вычесть из него 2; если нулевым, то заменить его на 10. Вывести полученное число.
f5.
Даны три целых числа. Найти количество положительных и количество
отрицательных чисел в исходном наборе.
f15.
Даны три числа. Найти сумму двух наибольших из них.

( Pascal ABC.net )

Составьте программу:
Дано 5-ти значное число (78906)
с помощью div и mod
нужно выделить цифры из числа.



Вы находитесь на странице вопроса "PASCAL-ABC.NET Здравствуйте,прошу помочь с не очень сложной задачкой.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.