Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

В двоичном файле "myfile.bin" записаны 2-байтные целые компоненты:

10-11 класс

1 8 -4 2 -7
Определить что будет напечатано в результате выполнения фрагмента программы:
FileStream fs = new FileStream("myfile.bin", FileMode.Open);
BinaryReader br = new BinaryReader(fs);
BinaryWriter bw = new BinaryWriter(fs);
Int16 x = br.ReadInt16();
x = br.ReadInt16();
x = br.ReadInt16();
Console.WriteLine(x);

NargizaNasirova 27 апр. 2014 г., 14:28:39 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sanvik1980
27 апр. 2014 г., 17:06:55 (10 лет назад)

Будет -4 так как происходит считывание из файла трёх чисел(при создании переменной x, и двух последующих присваиваниях), а третье число как раз -4.

+ 0 -
Eternal925
27 апр. 2014 г., 18:00:01 (10 лет назад)

C#

Ответить

Другие вопросы из категории

Дан одномерный массив положительных целых чисел. Последовательно преобразовать этот массив по следующему алгоритму: Находится первый максимальный элемент

и устанавливается первым в массиве, затем из оставшихся находится минимальный элемент и устанавливается вторым в массиве, после чего отыскивается из оставшихся элементов максимальный и устанавливается третьим в массиве и т.д. Размерность массива задается с клавиатуры.
Помогите, пожалуйста, не получается.

Помогите! Исправте ошибку. Условие было таким y:=√(1+4+9+...+36+49)

Var x: integer, y: real
BEGIN
x := 1; y := 0;
while x <= 7 do
begin
y := y+sqrt(x*x);
x := x+1;
end;
y := sqrt(y);
writeln (y);
END.



Читайте также

Однажды, посетив магазин канцелярских товаров, Вася купил X карандашей, Y ручек и Z фломастеров. Известно, что цена ручки на 2 рубля больше цены

карандаша и на 7 рублей меньше цены фломастера. Также известно, что стоимость карандаша составляет 3 рубля. Требуется определить общую стоимость покупки.

Входные данные

В единственной строке входного файла INPUT.TXT записаны три натуральных числа X, Y и Z через пробел, каждое из которых не превышает 109.

Выходные данные

В выходной файл OUTPUT.TXT выведите одно целое число – стоимость покупки в рублях.

Помогите решить на с++ или pascale срочно

Таймер - это часы, которые умеют подавать звуковой сигнал по прошествии некоторого периода времени. Напишите программу, которая определяет, когда должен быть подан звуковой сигнал.Входные данныеВ первой строке входного файла INPUT.TXT записано текущее время в формате ЧЧ:ММ:СС (с ведущими нулями). При этом оно удовлетворяет ограничениям: ЧЧ - от 00 до 23, ММ и СС - от 00 до 60.Во второй строке записан интервал времени, который должен быть измерен. Интервал записывается в формате Ч:М:С (где Ч, М и С - от 0 до 109, без ведущих нулей). Дополнительно если Ч=0 (или Ч=0 и М=0), то они могут быть опущены. Например, 100:60 на самом деле означает 100 минут 60 секунд, что то же самое, что 101:0 или 1:41:0. А 42 обозначает 42 секунды. 100:100:100 - 100 часов, 100 минут, 100 секунд, что то же самое, что 101:41:40.



Вы находитесь на странице вопроса "В двоичном файле "myfile.bin" записаны 2-байтные целые компоненты:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.