Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите расписать программу по строчкам (за что каждая строка отвечает)

10-11 класс

#include <iostream>
#include <cstdlib>
using namespace std;
int main() {

int n;
float sum=0;
cout<<"Vvedite n: ";

cin>>n;

float a[n+1], b[n+1];

for (int i=1; i<=n; i++){
system("cls");
cout<<"Vvedite "<<i<<"-e chislo massiva a: ";
cin>>a[i];

sum+=a[i];

b[i]= sum/i;
}

system("cls");

cout<<"B = [";
for (int i=1; i<n; i++){
cout<<b[i]<<", ";
}

cout<<b[n]<<"] ";

system("pause");
return 0;
}

Sonechka772 10 нояб. 2013 г., 22:07:22 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
POLICE611
11 нояб. 2013 г., 0:04:13 (10 лет назад)

#include <iostream> /*Заголовочный файл, который отвечает за потоковый ввод/вывод (cout/cin).*/
#include <cstdlib>/*Заголовочный файл, подключается для функции system().*/
using namespace std;/*Пространство имен std. Все имена стандартных функций расположены именно в этом пространстве имен.  */
int main() { //Начало главной программы.

int n; /*Количество чисел в массиве а и b.*/
float sum=0; //Переменная, которая отвечает за сумму.

cout<<"Vvedite n: "; /*Ввод количества элементов массива. (Тут ошибка,
если вы хотите вводить количество элементов массива, вам нужно использовать динамическое выделение памяти. То есть, float *a = new float [n], тогда эти две строки пойдут. А так лучше задать константную размерность двух массивов (const int n = 10 (например))).*/

cin>>n;

float a[n+1], b[n+1]; /*Массивы.*/

/*Теперь идет запись элементов в массив A, индекс пробегает по каждому 
элементу массива записывает значение, которое вводит пользователь.*/
for (int i=1; i<=n; i++){
system("cls"); /*Очищение консоли (экрана).*/
cout<<"Vvedite "<<i<<"-e chislo massiva a: "; /*На экран выбивает сообщение пользователю, что бы он ввел с клавиатуры значения a[i] элемента.*/ 
cin>>a[i]; /*Ввод значения с клавиатуры.*/

sum+=a[i]; /*Добавление элемента к сумме. (sum = sum+a[i])*/

b[i]= sum/i; /*Запись в массив b. */
}

system("cls"); /*Очищение экрана.*/

 /* Вывод массива b.*/

Ответить

Читайте также

Ребят,срочно срчно хелп!!!

Помогите решить Д/З по ИКТ

1.считая,что каждый символ кодируется одним байтом,оцените информационный объём следующего предложения в одном килограмме 1000 грамм

2.В бассейне ведётся наблюдение за температурой воды. результатом одного измерения является целое число от +10 до +35 градусов,которое записывается при помощи минимального количества бит. Было сделано 27 измерений. Определите информационный объем всех результатов наблюдений

3.Световое табло состоит из лампочек,каждая из которых находится в одном из двух состояний("Включено" или "Выключено"). Какое наименьшее количество лампочек должно находиться на табло,чтобы с помощью его можно было передать 200 различных сигналов?

ПОМОГИТЕ СРОЧНО ПЖЛСТ!!!

Автоматизированная система управления кадрами предприятия хранит личные дела работников в следующем формате: каждое личное дело
содержит 12 страниц, по 36 строк на каждой странице, по 64 символа в каждой строке, каждый символ кодируется одним байтом. Определите количество личных дел, хранимых в автоматизированной системе, если известно, что все данные занимают в памяти компьютера 13,5 мегабайта.

Помогите написать программу по Информатике! Найти произведение двузначных нечетных чисел, кратных

13.

Нужно написать программу на цикле с предусловием, на Паскале.

помогите решить задачу по информатике... Племя Мумбу-Юмбу использует алфавит из букв: αβγδεδεζλμξζφψ, точки и для разделения слов используется пробел. Скол

ько информации несет свод законов племени, если в нем 12 строк и в каждой строке по 20 символов?

Кодирование текстовой, графической и звуковой информации 1) Считая, что каждый символ кодируется одним байтом, определите, чему равен информационный

объем следующего высказывания Жан-Жака Руссо: Тысячи путей ведут к заблуждению, к истине – только один. 1) 92 бита 2) 220 бит 3) 456 бит 4) 512 бит 2) Считая, что каждый символ кодируется 16-ю битами, оцените информационный объем следующей пушкинской фразы в кодировке Unicode: Привычка свыше нам дана: Замена счастию она. 1) 44 бита 2) 704 бита 3) 44 байта 4) 704 байта 3) Для хранения растрового изображения размером 64 на 64 пикселя отвели 512 байтов памяти. Каково максимально возможное число цветов в палитре изображения? 1) 16 2) 2 3) 256 4) 1024 4) Разрешение экрана монитора – 1024 х 768 точек, глубина цвета – 16 бит. Каков необходимый объем видеопамяти для данного графического режима? 1) 6 Мбайт 2) 256 байт 3) 4 Кбайта 4) 1,5 Мбайт 5) Производится одноканальная (моно) звукозапись с частотой дискретизации 48 кГц и глубиной кодирования 16 бит. Запись длится 2 минуты, ее результаты записываются в файл, сжатие данных не производится. Какое из приведенных ниже чисел наиболее близко к размеру полученного файла, выраженному в мегабайтах? 1) 11 2) 12 3) 13 4) 20

c решением



Вы находитесь на странице вопроса "Помогите расписать программу по строчкам (за что каждая строка отвечает)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.