Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите! Очень-очень нужно!

5-9 класс

Хотя бы несколько заданий!

Ckadel 23 нояб. 2013 г., 3:18:04 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Eugenas
23 нояб. 2013 г., 3:48:41 (10 лет назад)

№1
var n:longint;
function sum_c(n1:integer):Longint;      
var L:Longint; R:Longint; c:Char; N:string;
begin Str(n1,N);    L := Length(N);    R := 0;   
if L>0 then begin
c := N[1]; if (c>='0') and (c<='9') then R := Ord(c)-Ord('0'); 
if L>1 then R := R + sum_c(StrToInt(Copy(N, 2, L-1)));   
end;   
sum_c := R;
end;
begin
readln(n); write(sum_c(n));
end.

№2
var i,k:integer;
s,subs:string;
begin
readln(s);
for i:=1 to length(s) do begin
subs:=subs+'1';
if pos(subs,s)<=0 then break;
end;  
k:=i;writeln(k);
end.

Ответить

Другие вопросы из категории

однажды жители Лилипутии решили выяснить сколько необходимо слив чтобы уравновесить яблоко . при этом Лилипуты выяснили что яблочко уравновеошивается на

чашечных весах персиков и славой. два ананаса уравновешиваются тремя персики .яблоко и слив уравновешивает ананас . помогите лилипутам решить задачу

..........................................................СРОЧНО..................................................................

Я знаю что это не по урокам,но всё же помогите!Купила МР3 и никак не могу скачать музыку...(Искала,искала делала пошагово и .....Вставила кабель,скачала музыку на комп. и когда перетаскиваю папку вылазит окно Вставте в диск "I"
Что єто значит?Помогите,пожалуйста!!!)☻☺☻

921.600 это 2 в какой степени ?

Читайте также

помогите плиз очень нужно:превратите одно слово в другое всякий раз заменяя по одной букве так,чтобы новое слово было существительным в именительном падеже

.
а)ночь-?-?-?-?-?-день
б)рота-?-?-?-?-?-полк
в)бант-?-?-?-?-?-коса
г)бег-?-?-?-?-?-?-?-шаг
д)море-?-?-?-?-?-?-суша
е)миг-?-?-?-?-?-?-?-век
помогите очень нужно,учительница ужасно строгая ненавидит меня помогите!

Помогите эти задания зависят на оценку за четверть 1) Записать алгоритм распознания среди всех треугольников прямоугольные, если таковых нет

вычислить периметр.

2) Последовательно вводится N целых чисел найти кол-во равных нулю.

помогите очень нужно!

Помогите!Очень нужно)))

В строке символов определить кол-во букв А.
Нужно составить программу на Паскале))

Помогите очень нужно)

Имеются переменые x,y,z для положительных чисел вывести удвоеное произведение для отрицательных в квадрат



Вы находитесь на странице вопроса "Помогите! Очень-очень нужно!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.