Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите с блок схемой!!пожалуйста(((

10-11 класс

program lab;
uses crt;
const nmax=20;
var a:array[1..nmax,1..nmax] of integer;
x:integer;
n,m,i,j,p,q,k:byte;
begin
writeln('Поиск неповторяющихся элементов двухмерного массива целых чисел');writeln;
randomize;
repeat
write('Введите количество строк...');
read(m);
until m in [1..nmax];
repeat
write('Введите количество столбцов...');
read(n);
write('Введите элементы двухмерного массива:');writeln;
until n in [1..nmax];
for i:=1 to m do
begin
for j:=1 to n do
begin
write(' [',i,',',j,']...');
readln(a[i,j]);

end;

end;
writeln('Исходная матрица:');

for i:=1 to m do
begin
for j:=1 to n do
begin

write(a[i,j]:4);
end;
writeln;
end;
writeln;
writeln('Неповторяющиеся элементы массива:');writeln;
for i:=1 to m do
for j:=1 to n do
begin
x:=a[i,j];
k:=0;
for p:=1 to m do
for q:=1 to n do
if a[p,q]=x then k:=k+1;
if k=1 then write(x,' ');
end;
end.

светамакс 01 марта 2017 г., 23:05:49 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Respectoon
02 марта 2017 г., 0:00:46 (7 лет назад)

Ну, как-то так

Ответить

Другие вопросы из категории

С помощью MS Excel рассчитать

и построить график функции: f(x) = 2х^3+3х-5х^2

, где х принадлежит [0;5], h = 0,5 Решение должно

быть получено в виде таблицы. Распечатать

таблицу в двух видах: с формулами и

итоговыми расчетами.

Помогите, пожалуйста с информатикой!! Буду очень благодарна!

В чем суть организационных мер информационной безопасности?

скорость передачи данных через ADSL-соединение равна 128000 бит/с. Передача текстового файла через это соединение заняла 1 минуту. Определите, сколько

символов содержал переданный текст, если известно, что он был представлен в 16-ти битной кодировке Unicode

помогите решить срочно

Читайте также

Помогите пожалуйста! 1)Построить развлетвляющийся алгоритм, записать алгоритмы ввиде блок-схемы и на алгоритмическом языке. Треугольник задан

длинами своих сторон – a, b, c. Определить является ли

он тупоугольным, прямоугольным или остроугольным.

2) Построить циклический алгоритм, записать ввиде блок-схемы и на алгоритмическом языке.

Построить алгоритм, который определяет количество студентов в группе,
чей рост превышает среднее для группы значение.

Нужно составить блок-схему алгоритма подготовки к сдаче к экзамену.

Я не могу сочинить этот "алгоритм", помогите ;)
Блок-схемы строить не надо, просто описать, что надо делать.

помогите пожалуйста нужна программа Паскаль вот задача (При каждом переходе через волшебный мост мужик, имеющий b рублей, удваивает эту сумму за счет

капитала черта (а рублей), стерегущего этот мост, после чего он должен уплатить черту дань в размере с рублей. Процесс этот продолжается до полного разорения одного из участников.Сколько будет совершено переходов моста?). вот блок схема пожалуйста сроочноо

Помогите составить блок-схему алгоритма и программу на алгоритмическом языке программирования БЕЙСИК обработки одномерного массива.Заполнение массива

элементами организовать путем ввода с клавиатуры.В одномерном массиве из N чисел вывести на экран отрицательные элементы и сообщите об их количестве.Пожалуйста,срочно надо.

Ну пожалуйста помогите сделать блок-схему к системе

у=х+3x^ если х больше или равно 0
у=61-х если х меньше 0
нужно сегодня



Вы находитесь на странице вопроса "Помогите с блок схемой!!пожалуйста(((", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.