Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

На день рождения Илья пригласил друзей. На праздничный стол поставили большой прямоугольный торт со сторонами A и B. Илья, известный всем своими причудами

5-9 класс

решил разделить торт следующим образом: он разрезал торт на равные квадратные куски максимальной площади. Квадратные куски торта раздал гостям, а сам взял то, что осталось. Сколько гостей смог угостить Илья?
Входные данные:
Во входной строке заданы два целых числа A и B (0 < A, B < 30000; A < B)

Выходные данные:
Вывести единственное целое число.

Пример входного файла (input.txt):
10 100

Kady1 01 апр. 2014 г., 15:44:54 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vitssss
01 апр. 2014 г., 17:28:45 (10 лет назад)

var
  A, B, x: integer;
  f: Text;

begin
  Assign(f, 'input.txt');
  Reset(f);
  read(f, p);
  Close(f);
  x := B div A;
  writeln(x)
end.

Тестовое решение:

10


Ответить

Другие вопросы из категории

Закончите ряд: монитор, принтер,плоттер(графопостроитель)...

1)клавиатура
2)мышь
3)колонки
4)системный блок

Помогите решить задачу)

Сформировать массив из 8 случайных вещественных чисел,принадлежащих промежутку {20;21) и вывести элементы этого массива в столбик в обратном порядке.

Маша, Оля, Лена и Валя - замечательные девочки. Каждая из них играет на каком-нибудь музыкальном инструменте и говорит на одном из иностранных языков,

инструменты и языки у них разные. Маша играет на рояле. Девочка, которая говорит по-французски, играет на скрипке. Оля играет на виолончели, а Лена не говорит по-немецки. Маша не знает итальянского языка, а Оля не владеет английским. Валя не знает французского, Лена не играет на арфе, а виолончелистка не говорит по-итальянски. Определите кто на каком инструменте играет и на каком языке говорит.
запишите кто где и в чем?

Читайте также

исло M называется средним арифметическим двух чисел A и B, если M равно (A + B) / 2. Васе на день рождения подарили два числа A и B. Именинник легко

вычислил их среднее арифметическое и так обрадовался, что потерял число B. Помогите Васе восстановить потерянное число.

Коле нужно было распечатать приглашения на День Рождения, но он забыл точное имя файла, поэтому попросил сестру найти его по маске *ello.doc, используя

поисковую систему компьютера. Какие имена файлов найдет компьютер из ниже перечисленных?
1/ helo.doc
2/hello.doc
3/Helolo.doc
4/Hello.doc

№19. Даны стороны треугольника. Определить является ли этот треугольник: а) равносторонним б) равнобедренным в) прямоугольным.

№20. Даны величины углов треугольника. Определить является ли это треугольник:

а) остроугольным

б) тупоугольным

в) прямоугольным

г) равносторонним

д) равнобедренным.

№21. Определить, какая из двух точек - M1(x1,y1) или M2(x2,y2) - расположена ближе к началу координат. Вывести на экран дисплея координаты этой точки.

№22. Даны действительные числа a, b, c, x, y. Выяснить, пройдет ли кирпич с ребрами a,b,c в прямоугольное отверстие со сторонами x и y. Просовывать кирпич в отверстие разрешается только так, чтобы каждое из его ребер было параллельно или перпендикулярно каждой из сторон отверстия.

№23. Написать программу, которая печатает True или False в зависимости от того, выполняются или нет заданные условия:

а) квадрат заданного трехзначного числа равен кубу суммы цифр этого числа;

б) сумма двух первых цифр заданного четырехзначного числа равна сумме двух его последних цифр;

в) среди цифр заданного трехзначного числа есть одинаковые;

г) среди первых трех цифр из дробной части заданного положительного вещественного числа есть цифра 0.



Вы находитесь на странице вопроса "На день рождения Илья пригласил друзей. На праздничный стол поставили большой прямоугольный торт со сторонами A и B. Илья, известный всем своими причудами", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.