Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Написать программы!!! Задание на фото

10-11 класс

Murod21 17 мая 2014 г., 5:19:14 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Chernikov9696
17 мая 2014 г., 5:49:28 (10 лет назад)

Успел написать только 2.

Код Pascal
1. Задание
1 uses crt;
2 var n,a,b:longint;
3    f:boolean;
4 begin
5 clrscr;
6 write('Введите натуральное число до 1000000 n=');
7 readln(n);
8 a:=n mod 10;
9 n:=n div 10;
10 f:=true;
11 while(n>0)and f do
12 begin
13   b:=n mod 10;
14   if b<a then f:=false
15   else n:=n div 10
16  end;
17 if f then write('Цифры справа налево образуют неубывающую последовательность')
18 else write('Цифры справа налево не образуют неубывающую последовательность');
19 readln
20 end.


2. Задание
1 read(n, m);
2 ans := 0;
3 for i := n downto 1 do
4 ans := sqrt(i*m + ans);
5 writeln(ans:0:6);

PS(Цифры перед программной строкой это номер строки, не забудь в паскеле вбить)

+ 0 -
AngAnanich
17 мая 2014 г., 8:43:24 (10 лет назад)

Тебе Pascal? Илил Delphi?

+ 0 -
Bui
17 мая 2014 г., 10:31:41 (10 лет назад)

или*

+ 0 -
AnnyaRosl
17 мая 2014 г., 13:06:25 (10 лет назад)

Паскаль

Ответить

Другие вопросы из категории

При регистрации в компьютерной системе каждому пользователю выдаётся пароль, состоящий из 15 символов и содержащий только символы Е, Г, Э, 2, 0, 1, 3.

Каждый такой пароль в компьютерной программе записывается минимально возможным и одинаковым целым количеством байт (при этом используют посимвольное кодирование и все символы кодируются одинаковым и минимально возможным количеством бит). Определите объём памяти, отводимый этой программой для записи 25 паролей.
1) 150 байт 2) 175 байт 3) 200 байт 4) 225 байт

чему равен 10*5 в двоичной системе?

варианты ответов
А) 01010101
В) 00110010
С) 00011101
Д) 11001100
Е) 10101010

Читайте также

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

Помогите написать программу в паскале. Задание:На плоскости даны 2 точки А (х1; у2) и В (х2; у2), определить какая из них находится дальше от начала коо

рдинат. Я поняла, что нужно найти их длины (формулы я знаю), а правильно написать программу не могу

Помогите человеку с отвратительной фантазией 1. Составить задание на разработку программы линейной структуры в QBASIC

2. Составить задание на разработку программы на разветвляющиеся структуры в QBASIC

3. Составить задание на разработку программы циклической структуры в QBASIC

Нужно задание + сама программа

Написать программы на языке С++

1) С клавиатуры вводится 2 числа - целое и вещественное. Программа выводит их сумму на экран.
2) Написать процедуру, которая умножает число типа int на число типа float на число типа double и выводит результат на экран
3) Написать процедуру, которая будет выводить любой текст, являющийся ее аргументом
4) С клавиатуры вводится 5 символов поочередно, программа выводит на экран акроним к слову которая образует эти 5 символов

Программа 4. Пользователь вводит угол . Написать программу, доказывающую основное тригонометрическое тождество. Программа 5. Пользователь вводит

число рядов. Написать программу подсчета мест в кинотеатре «Оскар», в соответствии со схемой кинотеатра, представленной ниже. На экран вывести итоговое количество мест.(вложение - 1 рисунок)

Программа 6. Найти значение выражения для вводимых с клавиатуры А, В и С. при А=4, В=2, С=5.(вложение - формула)

Программа 7. Написать программу, вычисляющую значения логического выражения . На экран вывести это значение.

Программа 8. Пользователь вводит число 0,515625. Написать программу, которая в точности повторяет алгоритм перевода данного числа из десятичной системы счисления в четверичную. На экран вывести окончательный результат.



Вы находитесь на странице вопроса "Написать программы!!! Задание на фото", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.