Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

числа Фибоначчи получаются следующим путем: первые 2 числа из них равны первому, каждое последующее путем суммы двух предыдущих. Найти первое из чисел

5-9 класс

Фибоначчи превышающие 1000.
надо сотавть программу начиная со слов
Dim a as integer...

Asiks 05 февр. 2015 г., 13:19:30 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dianasnarskaya
05 февр. 2015 г., 16:18:45 (9 лет назад)

Sub Main()
        Dim a As Integer = 1
        Dim b As Integer = 1
        Dim c As Integer 
        Do While (a < 1000)
            c = a
            a = a + b
            b = c
        Loop
        Console.Write(a)
        Console.Read()
    End Sub

Это на VB.NET, а 6.0 у меня нету:)


+ 0 -
27071974
05 февр. 2015 г., 17:05:44 (9 лет назад)

VB 6.0 или VB.NET?=)

Ответить

Другие вопросы из категории

два сообщение содержит одинаковое количество символов, количество информации в первом тексте в 1,5 раза больше чем во втором , сколько символов

содержат алфавиты с помощью которого записаны сообщения стало известно что число символов в каждом алфавите не прерывает 10 и на каждый символ приходится целое число битов?
Нужно полное решение, знаю что ответ 3 и 2 символа

Люди капееец помогите)))
Составьте программу вычисления

количества трехзначных чисел, у которых первая цифра меньше третей на 1.
Прошу, срочно.

Читайте также

Числа Фибоначчи строятся следующим образом: 1, 1, 2, 3, 5, …. В этой последовательности, начиная с третьего числа, каждый следующий член равен сумме двух

предыдущих. Получаем, что, например, шестое число равно 8, а десятое - 55.

Требуется написать программу, которая определяет, является ли заданное число числом Фибоначчи.

1. Сформируйте и выведите на экран массив из девяти элементов, каждые три последовательных элемента которого составлены по следующему правилу:

1-й равен случайному трехзначному числу;
2-й равен текущему индексу, увеличенному в 10 раз;
3-й равен сумме двух предыдущих элементов.

(программу надо выполнить в Паскале)

1)найти количесво делителей натурального числа,сколько из них чётных? 2) дано натуральное число: найти две первые цыфры числа

верно ли,что первая цыфраа данного числа чётная?

3)найти все трёхзначные числа,которые состоят из разных цыфр,а их сумма равна А(А вводится с клавиатуры)

4)найти все симметричные натуральные числа(палиндромаиз промежутка от А до В(А и В вводится с клавиатуры)

у исполнителя Арифметики 2 команды,которым присвоены номера: 1)прибавь 2 2)умножь на 3.Первая из них увеличивает число на экране на 2,вторая утраивает

его. запишите порядок команд в программе преобразования числа 12 в число 122,содержащей не более одной,то запишите любую из них. Ребят прошу объяснить и решить,очень надо,СРОЧНО!ПОМОГИТЕ ПОЖАЛУЙСТА!ОЧЕНЬ ОЧЕНЬ НАДООО!ПЛИИИЗ

У исполнителя Удвоитель две команды, которым присвоены номера: 1. умножь на 2 2. прибавь 3 Первая из них увеличивает число на

экране 2 раза, вторая - прибавляет к числу 3.

Составьте алгоритм получения из числа 1 числа 38, содержащий не более 5 команд. В ответе запишите только номера команд.

(Нопример, 12211 - это алгоритм:

умножь на 2

прибавь 3

прибавь 3

умножь на 2

умножь на 2

который преобразует число 1 в 32.)

Если таких алгоритмов более одного, то запишите любой из них.



Вы находитесь на странице вопроса "числа Фибоначчи получаются следующим путем: первые 2 числа из них равны первому, каждое последующее путем суммы двух предыдущих. Найти первое из чисел", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.